[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Need help on missing Dia shape icons

Camaleón wrote:
On Tue, 14 Feb 2012 21:35:04 -0600, luger wrote:

I just installed the "dia" package, dia starts up fine but immediately
gives me a warning:

failed to load icon for file
  cause=Couldn't recognize the image file format for file

and also tells me there are 49 more messages.


The rest of the messages also point to PNG files?

How about running the application (dia) from an empty/clean user?

Although the error above seems like pointing to some sort of package/
library ("libgdk-pixbuf2.0-0" or maybe "libpng12-0") corruption :-?

Thanks Camaleón,

Yes, the rest of the (error) messages do point to the various other shape files and all have .png extension.

Tried creating user "guest", then started "dia" from that user. Exactly same results.

I completely uninstalled and then reinstalled "libgdk-pixbuf2.0-0", "libpng12-0", along with "dia", "dia-common", "dia-libs", and "dia-shapes". Before reinstalling, removed /usr/share/dia and the ".dia" configuration directory under the username I'm using. Still no change in either dia or synaptic.

I cannot help but think my synaptic problem is related, so I tried starting synaptic from a konsole window (as root) and it displayed a lot of similar messages, only they were in reference to xpm files. Here's a typical synaptic message:

synaptic:3454): Gtk-WARNING **: Could not load image
'synaptic_mini.xpm': Couldn't recognize the image file format for file

I note that the two lib packages you mentioned are used by a multitude of applications and include some that I know are working satisfactory.

OK, something is messed up, either through my error or from upgrading Wheezy. All suggestions welcome.


Reply to: