[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Get to the bottom of what is running my networks

I'd like to know exactly how to start/stop retart etc the network

But first it seems one must determine what is actually running them.

in /var/log/boot  I see:

grep -i NetworkManger /var/log/boot
Mon Feb 13 13:27:14 2012: Starting network connection manager: NetworkManager.

OK, I found the thing running with:

# ps wwaux|grep NetworkManager
 (wrapped for mail)
| root 1251 0.0 0.2 26320 4868 ?  Ssl Feb13 0:01
| /usr/sbin/NetworkManager 
| root     29922  0.0  0.0   2532  1164 ?        S    
| 11:10   0:00 /sbin/dhclient -d -4 -sf 
| /usr/lib/NetworkManager/nm-dhcp-client.action -pf
| /var/run/dhclient-eth1.pid -lf
| /var/lib/dhcp/dhclient-d742aae7-0056-4428-acab-e14977d7aed8-eth1.lease
| -cf /var/run/nm-dhclient-eth1.conf eth1

Then followed with an attempt to find out what package[s] was involved.

First running `apt-get check' to make sure my database was up to par, then:
apt-cache search nm-dhcp-client.action

  <no output>

So I tried a few more in /usr/lib/NetworkManager:

ls /usr/lib/NetworkManager/
  ifblacklist_migrate.sh             nm-openvpn-service
  libnm-settings-plugin-ifupdown.so  nm-openvpn-service-openvpn-helper
  nm-avahi-autoipd.action            nm-pptp-service
  nm-crash-logger                    nm-vpnc-service
  nm-dhcp-client.action              nm-vpnc-service-vpnc-helper

Tried several, but none gave any output to apt-cache search.

Even apt-cache search  /sbin/dhclient gave no output.

How can I have all these tools on my machine and apt doesn't know
about them?

How can I find which package is doing such an important job as
starting the network.  And how can I bring that function directly
under my control only?

When I click the `network' icons in kde menus, I get this worthless
little weak interface that offers access to only incidental things,
not the main work of starting/stopping and actually allows no way
whatsoever to access even those.

It offers 3 tabs, hostname, dns, hosts and has an unlock button.  When
I push the unlock button I get this absolutely useless dialog that
offers a place for passwd (greyed out) and a drop down list to select
user.  Obviously the idea is to select a user and then the password
field will light up.

Dropping the list down I see all users except my user and root.  What
could be more useless?  I don't get it, am I likely to find another
icon that offers me a chance to transplants mammary glands into a bore

Honestly it is confusing... surely there is some straight forward way
by now on this modern of a version of debian to simply work with the
tools that control networking...

Command line is my preferred idiom, but anything would be a good

There must be a quick and easy way to start stop cleanly without major
study and scrutinizing of vast man pages or such.

Can anyone provide a simple step by step procedure?

Another distro I've used worked with a simple 
/etc/init.d/net.eth[0-9] start/stop/status

And a brief and easily understood configuration in /etc/conf.d/net.

Do we have anything similar?  A basic underlying control mechanism
that supersedes any add-on gui bunkem?

Reply to: