[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't get NIC Bonding with active-backup working

On 30/01/2012 17:22, Camaleón wrote:
> On Mon, 23 Jan 2012 11:29:07 +0000, Shaun wrote:
>> output from cat /etc/network/interfaces
> (...)
> I have the same setup as yours in my lenny servers but with a difference: 
> both cards are connected to the same physical switch in the same VLAN.
> Mmm... have you tried the other way round? Disconnect eth1 and see if it 
> works.

I've tired that by setting the active interface from the command line
with ifenslave -c.  Didn't make a difference the other way around.

> Another thing I would test is with no bonding setup at all, configure 
> both ethernet cards separately and try to ping with both of them, i.e.:

Yes I tried this just to eliminate cable/NIC/switch. They work fine when
configured independently with different IPs.

Also when I do arp -a (via remote console access via iDRAC like
technology) I see the arp table is empty following failover. It has
entries prior to failover.

I have to login via the remote-console access and restart networking to
get it up again.  I can only think it's something to do with the switch
but not sure how to prove this. I can also get my hosting company to
connect both NICS to the same switch and I can try testing again? But I
would lose the switch redundancy this way :(

Is there anything further I can do to debug or eliminate things? Sadly I
don't have any access to any of the following or proceeding hops to run
tcpdump or such stuff.


Reply to: