[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[SOLVED] Squeeze, Radeon HD 6310, black screen on Resume

On Mon, Dec 05, 2011 at 04:15:30AM -0500, Jeff Gordon wrote:
> Hi, Folks --
> I'm installing Squeeze on an Acer Aspire 5250 with Radeon HD 6310 as a
> Christmas gift for my sister.  All went well during install but I get
> nothing but a black screen on Resume from Suspend.  Even Power Off and
> Power On again doesn't clear it -- I've had to remove the battery each
> time to get back to 'normal'.  The kernel is 2.6.32-5-amd64.
> I've searched the 'Net extensively on this and tried a variety of tips
> but nothing so far has worked -- have set 'radeon modeset=0' as advised
> by one person, for example, but nothing seemed to change.  I expect there
> might be a specific 'quirk' that could be set for this card but I haven't
> yet found any info that seems applicable.
> I gather this problem is fixed in the 2.6.35 kernel but haven't found one 
> at Debian, and don't want to move all the way up to the 3.1 kernel.

Having encountered additional problems with Debian on this laptop, I "bit the
bullet" and went ahead with an upgrade to Wheezy.  The path to that wasn't
entirely smooth -- the first thing that happened was a completely scrambled
image, both console and desktop, with the 3.1 kernel.  It was fortunate
I still had the 2.32 kernel installed -- but the point is, after successfully 
upgrading, and _then_ installing firmware-linux-nonfree, Resume after 
Sleep/Suspend is now working the way it ought to. :-)


 -- Jeff --   <http://www.wellnow.com>

 "There's nothing left in the world to prove.  All that's worth doing
  is to love one another, using whatever means are available to serve."

Reply to: