[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Wheezy - External HDD Not Mounting

On Thu, 13 Oct 2011 00:46:44 -0400, shuttah wrote:

> Hello again, and thanks again Camaleón for responding.
>> On Wed, Oct 12, 2011 at 1:26 PM, Camaleón <noelamac@gmail.com> wrote:
>> >
>> > On Wed, 12 Oct 2011 12:57:15 -0400, k s wrote:
>> >
>> > The one i am having a problem with is the WD My Book, also using a
>> > NTFS filesystem, and has AC Power. It holds 2TB. I just wanted to say
>> > that again because my syslog may be mentioning both.
>> NTFS also? Then run an complete scan disk and defrag from a windows
>> machine.
> As stated earlier, i do not use Windows, and don't own a Windows box.
> However, i do use the NTFS Filesystem on certain disks as there are
> devices i use which will only read from NTFS or FAT, and from those
> choices NTFS is optimal.

Yes, but NTFS is not a native file system for linux. And unlike FAT, that 
is quite well supported by linux and other OSes for reading and writing 
operations, NTFS specs were not full-disclosed and the linux 
implemenation for NTFS is not at the same level as FAT. There are no 
problems (or there shouldn't be) when reading these kind of volumes but 
writing is a different thing.

So when you have to deal with NTFS (which means you have access to a 
windows box) it is better to use windows native tools to test and repair 
and NTFS filesystem.

In brief, there is always a risk in using NTFS from a non-windows 
operating system.
> Moving forward with this... I unplugged all of my other external USB
> hard drives, and completely shut down my computer.
> I booted back into Wheezy, inserted the problematic USB Hard Drive and
> Nautilus popped up with the contents open for me to explore.
> As soon as i tried to open a folder through Nautilus, the window closed
> and no errors were given.

Godd, but again, have you tried the manual mount?

I insist in this point because:

1/ Any error you get will be quickly displayed in front of you :-)

2/ In the event there is a problem with GNOME of FUSE tools, the disk 
will be able to be mounted manually

> dmesg gave me this -


> [ 2477.340425] end_request: I/O error, dev sdc, sector 6297232 [
> 2477.340431] Buffer I/O error on device sdc1, logical block 786898 [
> 2477.340438] Buffer I/O error on device sdc1, logical block 786899 [
> 2477.340444] Buffer I/O error on device sdc1, logical block 786900 [
> 2477.340450] Buffer I/O error on device sdc1, logical block 786901 [
> 2477.340456] Buffer I/O error on device sdc1, logical block 786902 [
> 2477.340461] Buffer I/O error on device sdc1, logical block 786903 [
> 2477.340468] Buffer I/O error on device sdc1, logical block 786904 [
> 2477.340474] Buffer I/O error on device sdc1, logical block 786905 [
> 2477.340480] Buffer I/O error on device sdc1, logical block 786906

I don't like those entries... let me search.

Okay, look at this article:


Which also agrees with my view of making a scandisk and running a defrag 
from a windows based machine. I would do it, just to discard there isn't 
any problem in the filesystem.

> A little worried, i took the drive to a friend's house & plugged it into
> his Windows machine...


> & all worked well. I even COPIED all 500Gigs off the drive in the event
> that it might fail.

Wise decision. Did you also run the filesystem check tools?

> It's been plugged into his machine, 

You first need to safely remove the unit...

> which was shut down and booted up three times in the last few hours and
> there have been no issues.
> lol, so sad. Wish Microsoft would make it easier to work with NTFS.

Yes, it's annoying :-(

Maybe you can partition the drive and use two filesystems, one to use 
from WIndows (formatted as NTFS) and the other to use from linux (with 
ext3/4, reiserfs...).

> Has anyone had any similar issues? Or found a way to get around this? Is
> this a bug i should file?

Yes, many people have experienced that, it's sadly a well-known ntfs "by-
design" issue. You will have to find a convenient way to be able to deal 
with NTFS by using different partitons as I already suggested.



Reply to: