[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: `Xorg -configure' failure

Scott Ferguson <prettyfly.productions@gmail.com> writes:

> On 07/10/11 02:44, Harry Putnam wrote:
>> [NOTE:  This post or very similar was also posted to
>> gmane.comp.freedesktop.xorg.]
> It's considered bad manners to cross post - why waste more peoples time?

Why is that wasting anyones time.  Some people read it here some
there, if they don't like the subject or content they move on.  Where
is the waste?

> So no point in me making suggestions - my tests were done with settings
> that are probably no longer relevant judging from what you've written
> here. I don't have time to read all the posts in various subsequent
> threads to try and find out what your current settings are.

I don't understand you.  What settings are you speaking of.  I've
tried to supply any information you requested.  Please say plainly
what information you want, instead of contained obliquely in a

My current setting haven't changed at all.  I'm talking here about
trying to come at the problem from a little different angle.  Although
I actually doubt it will work, because I suspect the same bug that is
preventing it working with xrandr will prevent xorg.conf using a
Virtual parameter too.

Further more, we have already hit upon commands that have done what I
wanted.  It no longer requires testing.  The problem is that the mouse
is not being allowed to wander out into the Virtual size.

>>>From Section "Screen"
>>   [...]
>>     Subsection "Display"
>>         Depth       24
>>         Modes       "1280x1024" #"1024x768" "800x600" "640x480"
>>         Virtual     2048 1536 
>>         ViewPort    0 0
>>     EndSubsection
>>   [...]
>> Its the virtual size I'm after. 
> Then change the virtual size - not the *display* size. That section
> refers to the display size for the default monitor (not even the monitor
> you currently use).

No, you are wrong there... but it's my fault for not fully explaining
the origin of that piece of xorg.conf.  That very xorg.conf was used
on a CRT, but when I changed to a 25.5 lcd that same section worked there
too when running Gentoo.

So what I said about it being the same hardware is true.
> If those are the setting you want, and they are supported by the
> *different display* - then that's all that needs to be in
> /etc/X11/xorg.conf - X will deal with everything else. However you will
> need to use xrandr to disable your other screens (TV and VGA).

What is all I need of xorg.conf?  Do you mean just what is printed
above between the elisions?  The subsection of the sub section.  Do
you mean it could just say:

     Subsection "Display"
         Depth       24
         Modes       "1280x1024" #"1024x768" "800x600" "640x480"
         Virtual     2048 1536 
         ViewPort    0 0

>> Its worked on this same hardware in
>> the past under Gentoo linux.
> Perhaps you "mean" the video card is the same...
> A CRT monitor is *not* a LCD monitor. So you *don't* have the same
> hardware. Monitors *are* hardware.

See above.  And sorry for misleading in previous posts.  That xorg
conf began life on a 17 inch CRT but was later used on the very
hardware including the 25.5 inch lcd monitor that I am using now.

> Gentoo doesn't use Nouveau - you do. So don't expect the same results
> when software and hardware have changed.

So is Nouveau incompatible with the ability to pan?  Do I need to
change drivers, scrap Nouveau?
>> And using xrandr to attain the virtual size has been discussed at some
>> length in another thread...
> Not on this list. Virtual size was discussed in passing. Panning was
> discussed at length.

Now I'm really confused.  When you speak of panning, what is being
panned into?  Is that not virtual size out beyond the monitors real

>> so far it hasn't worked.  It appears to be
>> because of a bug caused by certain code that prevents the mouse from
>> panning out into the virtual size. 
> AFAIK there is no such bug.

>> I'm trying to sneak up on that bug
>> by setting a virtual size in xorg.conf... It seem doubtful it will
>> work but I'm not sure what the details of the mouse panning bug are.
> Because no such bug exists.

>> I'm not sure there is an actual Debian bug about the mouse problem but
>> I see several other OS's are reporting such a bug.  Ubuntu and Redhat
>> specifically.
> Please post links to these bugs.

At least one (from redhat) was already mentioned in the previous
thread: Subject: wrestling with xrandr


Note especially comment 22

Seems to describe exactly what I see when for example I run one of the
commands you suggested:

xrandr --output DVI-I-1  --mode 1440x900 --panning 1680x1050

I can see the screen enlarge quite a lot by watching the picture I'm
using as background grow quite noticeably, and the mouse can then
partially disappear at the monitor boundary... a slight bit more than
it could prior to running the command.  Further, a fluxbox panel
that was placed at the bottom of my screen has now moved clear out of site
and cannot be accessed with the mouse because it is not allowed to pan.


>> I haven't been able to generate xorg.conf so far because 
>> `Xorg -configure' fails without generating a file.
> For future reference you can't generate an xorg.conf from within a X
> session using "Xorg -configure" (you can generate one from
> /var/log/Xorg.0.log though).

I was aware of that requirement and in fact ran Xorg -configure after
closing X which drops me into a text console.

How do you go about generating one from /var/log/Xorg.0.log?
Do you mean by hand or what?

>> [177036.474] (II) UnloadModule: "vmwlegacy"
>> [177036.474] (II) Unloading vmwlegacy
>> [177036.474] (II) Failed to load module "vmwlegacy" (already loaded, -1219177616)
>> [177036.474] (EE) vmware: Unexpected failure while loading the "vmwlegacy" driver. Giving up.
>> [177036.474] (II) UnloadModule: "vmware"
>> [177036.474] (II) Unloading vmware
>> [177036.474] (EE) Failed to load module "vmware" (a required
>> submodule could not be loaded, 136110067)
> <snipped>
> ^^^^^^^^^^^^^^Is this a vmware machine??


>> [177036.520] (==) ServerLayout "X.org Configured"
>> [177036.521] (**) |-->Screen "Screen0" (0)
>> [177036.521] (**) |   |-->Monitor "Monitor0"
>> [177036.521] (**) |   |-->Device "Card0"
>> [177036.521] (**) |-->Screen "Screen1" (1)
>> [177036.521] (**) |   |-->Monitor "Monitor1"
>> [177036.521] (**) |   |-->Device "Card1"
>> [177036.521] (**) |-->Screen "Screen2" (2)
>> [177036.521] (**) |   |-->Monitor "Monitor2"
> ^^^^^^^^^*Those* screens fit within the "virtual screen".

I don't understand what you mean, and obviously do not understand what
`virtual screen' is supposed to be.

I took it to be the part of the screen that is out where you can't see
it.  The part I'm trying to pan into.

Are you able to pan around on your setup?

Reply to: