[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: `Xorg -configure' failure

On 07/10/11 02:44, Harry Putnam wrote:
> [NOTE:  This post or very similar was also posted to
> gmane.comp.freedesktop.xorg.]

It's considered bad manners to cross post - why waste more peoples time?

So no point in me making suggestions - my tests were done with settings
that are probably no longer relevant judging from what you've written
here. I don't have time to read all the posts in various subsequent
threads to try and find out what your current settings are.
> Setup:
> Single user machine running Debian (wheezy) 3.0.0-1-686-pae
> Graphics card: Nvidia FX 5700 LE
> At present X is setup without any xorg.conf.  Its pretty much the
> defaults after install of new install medai, other than I've taken
> gdm3 out of service, preferring to `startx', and this I do with no
> problems.
> However, I wanted to use an old setting from previous OS's on this
> same hardware that was set in /etc/X11/xorg.conf.
> I thought I'd generate an xorg.conf and try to edit in my changes.
> The desired addition from previous OS (Gentoo linux). 
>>From Section "Screen"
>   [...]
>     Subsection "Display"
>         Depth       24
>         Modes       "1280x1024" #"1024x768" "800x600" "640x480"
>         Virtual     2048 1536 
>         ViewPort    0 0
>     EndSubsection
>   [...]
> Its the virtual size I'm after. 

Then change the virtual size - not the *display* size. That section
refers to the display size for the default monitor (not even the monitor
you currently use).

If those are the setting you want, and they are supported by the
*different display* - then that's all that needs to be in
/etc/X11/xorg.conf - X will deal with everything else. However you will
need to use xrandr to disable your other screens (TV and VGA).

> Its worked on this same hardware in
> the past under Gentoo linux.

Perhaps you "mean" the video card is the same...

A CRT monitor is *not* a LCD monitor. So you *don't* have the same
hardware. Monitors *are* hardware.

Gentoo doesn't use Nouveau - you do. So don't expect the same results
when software and hardware have changed.

> And using xrandr to attain the virtual size has been discussed at some
> length in another thread...

Not on this list. Virtual size was discussed in passing. Panning was
discussed at length.

> so far it hasn't worked.  It appears to be
> because of a bug caused by certain code that prevents the mouse from
> panning out into the virtual size. 

AFAIK there is no such bug.

> I'm trying to sneak up on that bug
> by setting a virtual size in xorg.conf... It seem doubtful it will
> work but I'm not sure what the details of the mouse panning bug are.

Because no such bug exists.

> I'm not sure there is an actual Debian bug about the mouse problem but
> I see several other OS's are reporting such a bug.  Ubuntu and Redhat
> specifically.

Please post links to these bugs.

> Another (related) bug #509699 would seem to indicate it won't work.
> ( http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=509699)

Did you read that bug report? I don't believe so or you'd have a better
understanding of what "virtual screen size" is - and why the actual bug
(three years ago) had nothing to do with virtual screen size (it was
where an actual screen was placed within a virtual screen).
Look for the comments by Brice Goglin (he's the one who can spell
"crash") :-)
The actual bug  (screen location within the virtual screen on a
multi-head video card) has since been fixed.

> I haven't been able to generate xorg.conf so far because 
> `Xorg -configure' fails without generating a file.

For future reference you can't generate an xorg.conf from within a X
session using "Xorg -configure" (you can generate one from
/var/log/Xorg.0.log though).

> I've included below, the output from running `Xorg -configure' as it was
> written to Xorg.0.log
> Here is just a grep for (EE) error lines, below is the full log.
> grep EE /var/log/Xorg.0.log
>         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
> [177036.473] (EE) Failed to load module "vmwgfx" (module does not exist, 0)
> [177036.473] (EE) vmware: Please ignore the above warnings about not being able to to load module/driver vmwgfx
> [177036.474] (EE) vmware: Unexpected failure while loading the "vmwlegacy" driver. Giving up.
> [177036.474] (EE) Failed to load module "vmware" (a required submodule could not be loaded, 136110067)
> [177036.522] (EE) [drm] No DRICreatePCIBusID symbol

> [177036.474] (II) UnloadModule: "vmwlegacy"
> [177036.474] (II) Unloading vmwlegacy
> [177036.474] (II) Failed to load module "vmwlegacy" (already loaded, -1219177616)
> [177036.474] (EE) vmware: Unexpected failure while loading the "vmwlegacy" driver. Giving up.
> [177036.474] (II) UnloadModule: "vmware"
> [177036.474] (II) Unloading vmware
> [177036.474] (EE) Failed to load module "vmware" (a required submodule could not be loaded, 136110067)

^^^^^^^^^^^^^^Is this a vmware machine??

> [177036.520] (==) ServerLayout "X.org Configured"
> [177036.521] (**) |-->Screen "Screen0" (0)
> [177036.521] (**) |   |-->Monitor "Monitor0"
> [177036.521] (**) |   |-->Device "Card0"
> [177036.521] (**) |-->Screen "Screen1" (1)
> [177036.521] (**) |   |-->Monitor "Monitor1"
> [177036.521] (**) |   |-->Device "Card1"
> [177036.521] (**) |-->Screen "Screen2" (2)
> [177036.521] (**) |   |-->Monitor "Monitor2"

^^^^^^^^^*Those* screens fit within the "virtual screen".


> [177036.524] Number of created screens does not match number of detected devices.
>   Configuration failed.

Reply to: