[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing icedtea-plugin from Sid on Wheezy system - was Re: openjdk-7-jre and Iceweasel

On 09/29/2011 03:37 PM, Lisi wrote:
On Thursday 29 September 2011 17:03:55 Dejan Ribič wrote:
Dne 29.9.2011 17:54, piše Lisi:
I am trying, without success, to run:


    I am not sure this works with openjdk-7 but try to install

It seems to be available only in Sid.

I have never tried to mix systems before.  I first thought of putting Sid into
my sources.list, installing icedtea-plugin and then commenting Sid out of my
sources.list.  But that won't work will it?  Becauseaafter adding Sid to
tehsources.list I would have to run update, would I not?  And I don't want
everything updated to Sid.

So where do I go from here?


Hi, Lisi.

I am by no means an expert at running "mixed" systems. But I can tell you my experience from a few weeks ago with this exact issue.

I had been happily using the icedtea plugin with the OpenJDK JRE on my old system running Wheezy. I got a new system and did a new installation of Wheezy on it and on my spare laptop, and there was no icedtea plugin to be found in the repository. I learned that the old icedtea plugin was going to be replaced by an icedtea-netx plugin -- or something with a name approximately along those lines. Anyway, nothing of the sort was currently available from the wheezy main repository.

I added the unstable main lines to my /etc/apt/sources.list file, then ran aptitude (interactive mode) and ran an update. I then searched for and selected ONLY the openjdk jre and the icedtea-netx and installed them. (I left all of the thousands of upgrades available on HOLD.) I then commented out the sid lines in the sources.list file and ran aptitude update again, and that reverted everything so that aptitude would not think that it needed to install a jillion upgrades.

It worked after a fashion, but dealing with the iceweasel browser version changes that have been making their way into wheezy and trying to keep the icedtea / netx plugin and jre from sid updated just got to be a pain, so I ripped them out of the system and stopped using Java for the time being. I've been waiting for a number of weeks for this stuff to get hashed out and make its way from unstable to testing, but I'm not holding my breath any longer. You, however, have a more compelling reason to want the function than do I. (I only used it for playing online crossword puzzles. Doh!)

If you subscribe to the distro-pkg-dev@open.jdk.net list you can see that there's a lot of activity -- and, apparently, a little bit of infighting, too. But I'm not sure we can expect to see a solution very soon -- at least not if I'm interpreting what I read there correctly. I'm guessing that those folks have to arrive at more suitable solutions before the package managers for the Debian Wheezy packages dare to bring the packages into Wheezy.

I use only the main repositories, not even deigning to use proprietary firmware on any of my systems. Obviously, I'm going to be stubborn and not install the Sun java jre. So I'm stuck until this is fixed. I love my Wheezy and don't want to go back to stable, but the Squeeze folks do have it better right now with regards to this particular issue. They still get to use FOSS for supporting Java applets.

Now -- if I've stuck my foot in my mouth, and someone has a better idea of what the heck is going on and when we might hope to see a fix for using Java applets in Wheezy (without resorting to the Sun JRE) I hope this person or persons will step right up, whack me in the head with a clue-by-four, and enlighten me. And then you (Lisi) and I will have an idea of how we should proceed.

Here's hoping you find the answer that I've just been waiting for and wishing for!

Best regards,

Reply to: