[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Recent Changes in CUPS and Foomatic Causing All-Black Printing from Browsers?


I'm reluctant to even bring this up because it's so darned weird.

I've got an HP OfficeJet 6310 (multi-function network device: printer, fax, scanner) that has worked flawlessly for a couple of years under Debian stable and testing.

I don't make use of the fax function, but both printer and scanner have "just worked" after I install the printer using the hp-setup script in interactive mode.

Then, recently on my Debian testing systems, there were some apparent hassles between foomatic and CUPS upgrades. Everything is back to normal after a couple of rounds of upgrades -- except for the fact that this one printer now only prints a wall of black when printing from a browser -- ANY browser. (iceweasel, midori, chromium)

The scanner function works fine. All other printers work fine. All other apps print fine to this printer. But if I try to print to this particular printer *directly from* a browser, all I get is a page full of black ink.

And here's the best part. If I print to file from a browser to create a PDF, and then open the PDF and print it to this printer -- that get's me a wall of black, too. (The PDF looks fine in the viewer, but it prints out all black.) But all other PDFs print out on this printer just fine. I can also copy contents of a Web page and paste them into LibreOffice Writer document, and that prints out fine -- other than the expected monkeying around with the page / text format.

Is this weird, or what?

I've removed the printer, purged its drivers and setup, re-installed. Nothing fixes it. I've also tried using the CUPS Web interface to modify the printer by assigning a different driver to it. I wanted to see if maybe a postscript driver would fare better. But the only OfficeJet 6300 printer driver listed in the CUPS interface now is hpcups 3.11.5. I think there used to be a slew of choices. Now only 1. And it doesn't work properly.

I don't even know what to make a bug report on. There are other Debian testing systems on the network that seem print just fine to this printer. They've had the same upgrades, but they're older installations of testing. (The two computers that are doing messed up printing are from a daily build image from mid-August.) I've found other irregularities with these recent installations. I wonder if d-i did something "funny" to the system configuration on these two computers during installation that is causing this behavior.

These two computers use Xfce and had XDM set as their default DM by the installer. (GDM had just become "obsolete" when this daily build was produced.)

I cannot for the life of me figure this out.

Can anyone suggest a way I can get this printer to work properly with browsers again?

Reply to: