[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ReInstall of System borked Admin Pwd for Apps

2011/9/4 Stephen Allen <marathon.durandal@gmail.com>:
> On Sun, Sep 04, 2011 at 08:04:20AM +0000, darkestkhan wrote:
>> 2011/9/3 Stephen Allen <marathon.durandal@gmail.com>:
>> > On Sat, Sep 03, 2011 at 11:32:00AM +0000, darkestkhan wrote:
>> >> /etc/sudoers contains informations about who has rights to access root
>> >> level privileges (though I know it can do much more, like giving only
>> >> limited privileges)
>> >>
>> >> at the bottom of /etc/sudoers you should have this line:
>> >> username ALL=(ALL) ALL
>> >>
>> >> where username is the name of user that will have root level
>> >> privileges, so in my case it is like this:
>> >> darkestkhan ALL=(ALL) ALL
>> >>
>> >>
>> >> You will probably have to run in maintenance (or rescue, forgot how it
>> >> was called) mode, after that (or reboot) everything should work
>> > ---end quoted text---
>> >
>> > Cool. Thanks for the help.
>> >
>> > Strange why that line isn't there aye?
>> >
>> Well, probably because maintainers can't be sure about which user
>> should have root level privileges, so it has actualized file without
>> asking question whether it should do so (this one is because of
>> synaptic, can't blame it - most (nontechnical) users won't notice
>> those changes, and in most cases system doesn't brake). As I'm
>> updating from command line I got information about changes in
>> /etc/sudoers but I decided to handle this manually as tool for merging
>> changes in config files is not too helpful (but it could be, arch and
>> gentoo are doing much better in this aspect)
> Unfortuantely the suggested fix didn't work. Must have something to do with PAM? Doesn't
> PAM interact with the Keychain and maybe SUDOERS to authorize a user wanting to run for
> example, Synaptic?

It should work... (there is space after right parenthesis (and it may
be that you it should be
username ALL=(ALL:ALL) ALL

but if it still doesn't work then I can't be of much help - it works
for me, though, admittedly I don't use PAM so it may be that it does
work until I will have to use something with PAM (or other similar

It has to be noted that things worked well without merging changes in
/etc/sudoers as long as programs were run by me - if program run by me
with root privileges was running different program then I got errors
that it can't find things in /sbin (and thus I knew that I have to
look at changes in /etc/sudoers)

Feel free to CC me.
jid: darkestkhan@gmail.com
May The Source be with You.

Reply to: