[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cups on wheezy problem

On 08/10/2011 10:27 AM, Camaleón wrote:
On Tue, 09 Aug 2011 14:13:08 -0400, Wayne Topa wrote:


Aug  9 11:26:08 dj kernel: [  551.816184] usb 3-1: usbfs: interface 0
claimed by usblp while 'usb' sets config #1

And "ls -l /dev/usblp1" returns...?

ls -l /dev/usb/lp1

Note: Bug#545288: CUPS 1.4.0-4 doesn't find  USB-printer  Date: Sun, 6
Sep 2009 12:39:46 +0200

And is the same as what I get in 2011????

Maybe not the same. It's a very old bug, arked as solved since 2009.

Cups interface Printer Tab
6P  HP LaserJet 6P      HP LaserJet 6P Foomatic/ljet4   Paused -
"/usr/lib/cups/backend/usb failed"

Maybe because the backend has changed and is no more under "/usr/lib/cups/

Draft   Draft HP6P      HP LaserJet 6P - CUPS+Gutenprint v5.2.7
Processing - "Waiting for printer to become available..."

[VT3 root@dj-WHEEZY]
~# dpkg -S /usr/lib/cups/backend/usb
dpkg-query: no path found matching pattern /usr/lib/cups/backend/usb.

That explains why CUPS fails.

[VT3 root@dj-WHEEZY]
~# dpkg -S /usr/lib/cups/backend/
foomatic-filters, cups, cups-pdf: /usr/lib/cups/backend

And "ls -l /usr/lib/cups/backend/" shows what available backends?

As of this mornings upgrade shows the same as below but includes usb now.
[VT3 root@dj-WHEEZY] **** This differs from the stable cups ~# lpinfo -v
network beh
file cups-pdf:/
direct scsi
network http
network socket
network lpd
network ipp
               ***** No USB  interface???
   USB today!

Nope, because it seems that usb is not a known interface/driver for your

Have you tried to set the printer from CUPS web interface?

As shown above, yes.  I still can't rule out udevd OR Cups as the

Why would no one else be having this problem?  Make no sense to me.

I would review the current open bugs for cups:

I don't usually go to the bugs page on debian.org directly but by the Google links when I am searching for the 'error of the day' :-(

I do however, maybe wrongly, rely on listbugs so here is what it has been saying for days now.
Fixed: cups/1.4.8-1
I am running 4.8-2 and an attempt to downgrade reports it could not find 4.8-1.

An attempt to print shows
Aug 10 12:28:13 dj kernel: [ 1029.762136] usb 3-1: USB disconnect, device number 2
Aug 10 12:28:13 dj kernel: [ 1029.762391] usblp1: removed
Aug 10 12:28:19 dj kernel: [ 1036.244036] usb 3-1: new full speed USB device number 3 using ohci_hcd Aug 10 12:28:19 dj kernel: [ 1036.411106] usb 3-1: New USB device found, idVendor=067b, idProduct=2305 Aug 10 12:28:19 dj kernel: [ 1036.411115] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0 Aug 10 12:28:19 dj kernel: [ 1036.411122] usb 3-1: Product: IEEE-1284 Controller Aug 10 12:28:19 dj kernel: [ 1036.411127] usb 3-1: Manufacturer: Prolific Technology Inc. Aug 10 12:28:19 dj kernel: [ 1036.422224] usblp1: USB Bidirectional printer dev 3 if 0 alt 1 proto 2 vid 0x067B pid 0x2305 Aug 10 12:28:19 dj mtp-probe: checking bus 3, device 3: "/sys/devices/pci0000:00/0000:00:12.0/usb3/3-1"
Aug 10 12:28:20 dj mtp-probe: bus: 3, device: 3 was not an MTP device

There is a 'something ?' causing weird mtp-probe call. I'll keep looking to see if I can figure out just what.

Funny thing is that the same thing is happening on Sid. I wonder how this got to wheezy in this condition??



And the same to you.  Have a nice day!

Reply to: