[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

shutdown problem in combination with autofs/NFS


occassionally our Debian 6 boxes don't shutdown. The shutdown process
hangs forever with the last messages:

  Turning off quotas:...Checking for running unattended-upgrades:

I assume, I found the reason for this issue, but no solution. Our linux
computers mount some directories via NFS. The directories /home and /sw
are managed by the automounter. /usr/local is a symlink to
/sw/local.debian-6 which is mounted from the NFS server. While shutting
down, sometimes the automounter finishes to early. Afterwards all
scripts in /etc/init.d which look for binaries in /usr/local/bin hang.
Until Debian 5 this wasn't an issue, because the automounter finishes at
a well defined time relatively to other services. But with the new
dependency based init system, this time seems to vary and sometimes the
automounter finishes to early. If this situation occurs, all local
terminals are dead and can be used for debugging. But from an open ssh
session I can restart autofs and then the shutdown goes further.

First I tried to remove /usr/local/bin from the PATH variable in
/etc/profiles. But this doesn't not help, because a lot of init scripts
define theire own PATH variable:

  # grep -l "PATH.*/usr/local/bin" /etc/init.d/*

Next we tried to adjust the dependencies in /etc/init.d/autofs. But we
didn't found a working solution.

Is there a simple solution or workaround for this?

I didn't filed a bug until now, because of the nonstandard configuration
with /usr/local via NFS/autofs. Or should I do this?

Ingo Rogalsky

Reply to: