[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Unable to create either bootable USB flashdrive or CD/DVDrom


This is not the first time I'm struggling trying to make a bootable
USB flashdrive. In fact, I've spent like 5-10 hours across various
times already, and I realize that I've been too stupid to document my
last endeavours enough to help me to get it to work this time (or
maybe I did and just something has changed with recent images?).

This is the first time though that I find myself even unable to create
a bootable CD or DVDrom. I've burned these and none of them boot on my
ThinkPad T61:

- MythBuntu to a DVD-R
- XMBC live CD to a DVD-R
- MythBunto to a CD-R
- Squeeze netinst to a DVD-R

The first three fail with either just the screen going black and
rebooting in an endless cycle or, in the case of XMBC (with 'quiet'
option removed in the boot menu) showing "Kernel panic - not synching:
VFS: Unable to mount root fs on unknown-block(1,0)". I then tried the
debian- image on a DVD-R, ("wodim
debian-"), in this case wodim told me "wodim:
Cannot fixate disk" at the end, but I can mount the disc and tar its
contents without a single error, so I'd say the disc is fine? But when
booting from it, the screen shows two random characters (otherwise
empty) and then it's frozen (except for the cursor in the top left
corner still blinking, but that's maybe handled by the HW or the

The laptop *does* boot from a XubunTOS-1.0 CDrom I burned years ago, though.

So I tried the next step (using unetbootin 549-1, recompiled from
testing on squeeze some time ago--I did this because the version in
Squeeze wouldn't work for me back then, the recompiled version did):

- MythBuntu to USB stick using unetbootin: shows "Kernel panic - not
synching: VFS: Unable to mount root fs on unknown-block(104,0)"
- MythBuntu to a second USB stick unetbootin, same
- Squeeze netinst using cat $image.iso > /dev/sdb  (device of stick):
doesn't even show boot menu
- Squeeze netinst using unetbootin: iirc not even the boot menu showed up

Then I tried compiling "usb-creator" from ubuntu, from
https://launchpad.net/ubuntu/oneiric/+source/usb-creator/0.2.31, on

- at first using dpkg-buildpackage, but there are dependencies on a
newer python-gobject and on gir1.2-gtk-3.0 and other libs, so I gave
- using "make", then running bin/usb-creator-gtk, gave same message as below,
- using "python setup.py install" then:

$ usb-creator-gtk
Traceback (most recent call last):
  File "/usr/local/bin/usb-creator-gtk", line 25, in <module>
    from usbcreator.frontends.gtk import GtkFrontend
  File "/usr/local/lib/python2.6/dist-packages/usbcreator/frontends/gtk/__init__.py",
line 1, in <module>
    from frontend import GtkFrontend
  File "/usr/local/lib/python2.6/dist-packages/usbcreator/frontends/gtk/frontend.py",
line 21, in <module>
    from gi.repository import GLib
ImportError: No module named gi.repository

Since I don't know what that issue is, I've given up.

Could you help me in any of these attempts? Of course I don't expect
you to help me debug problems with Mythbuntu or XMBC, but as you see
there are already multiple Debian-only problems I'm dealing with.


Reply to: