[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


On Sat, Jul 2, I wrote:
> Todays testing update, safe-upgrade and full-upgrade totally killed my X.

After that, I went to the TV and saw some news. When I returned to the computer, I already found important answers:

Chris Brennan:
> Try reinstalling the nvidia driver, the kernel likely changed during
> your upgrade and the driver needs to have his kernel module recompi- > led against the new kernel version. Try that and report back.

I aptitude-searched "nvidia" and tried to reinstall nvidia-kernel-2.6-
amd64; answer: not found (right now it no longer shows up in aptitude
search nvidia). Then, because there was a line "nvidia-kernel-2.6.32-5- amd64", I tried to install nvidia-kernel-2.6.39-2-amd64, my actual uname kernel. I should have known better: not found.

Patrick Wiseman:
> I just had exactly the same problem. nvidia-glx ... breaks every- > thing ... . Using aptitude, I manually removed all of the nvidia > packages ... , installed xorg-video-nouveau (although I'd rather use > the proprietary driver), moved /etc/X11/xorg.conf ... , after all of > which 'startx' finally worked. ... albeit with the nouveau driver. > Who knows? Maybe it will turn out to be OK.

Since purging the packages by hand which had an 'i' in aptitude search nvidia seemed less work than trying to reinstall them, I now tried the method of Patrick - with one difference: instead of moving /etc/X11/xorg.conf, I again changed its driver line in section "device" to nouveau - and SUCCEDED: After a reboot xdm started X normally, not even startx was necessary. So, my problem was solved, and what is especially important: extremely fast, and solely by help from debian-users-list. The main mistake I made before asking for help was not to remove the nvidia files.

Sven Joachim:
> I think the problem is the new multiarch path of libGL.so.1¹.  The
> nvidia packages divert this file and replace it with their own ver- > sion, and the versions in testing have not been adapted to the new > filesystem layout yet. Actually they are uninstallable, because > libgl1-mesa-glx breaks libgl1-nvidia-alternatives (<= 275.09.07-1),
> the version in wheezy.

Looks plausible.

> This should serve as a warning to closely look out which packages are > to be removed by a full-upgrade and back out if necessary.

You are right. I use Testing since it came up in Potato times, and this is the third time that an upgrade made real difficulties. All of those were with X. I am afraid by now I am much too audacious. Since I reti-
red 20 years ago I increasingly solved my problems by instinct and
feeling instead of by knowledge and learning, a behaviour which I never allowed my pupils and teachers while in work.


You are right again, but while writing those thoughts down the panic vanished. Anyhow, a new install of wheezy with partitions remaining
unchanged seems an attractiv experiment, but for this, I am afraid,
my audacity is not strong enough.

> Install the xserver-xorg-video-fbdev and xserver-xorg-video-vesa
> packages if they are not installed already, ...

Both are installed, but there is something in /usr/share/bug which I
shall read tomorrow.

> The nvidia packages will not be installable for a few days,
> unfortunately.

Thank you, Chris, Patrick and Sven, for your fast and important answers. And, please, do excuse the talkativeness of an old man.


Dieser Account aktzeptiert nur Mails, die an von mir abonnierte Listen
gerichtet sind. - This account accepts only postings which are directed
to lists subscribed by me. - Questo account accetta solo messaggi che
si rivolgono a liste sottoscritte da me.

Reply to: