[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Wheezy: monitor signal lost when leaving X

Op Fri, 20 May 2011 13:37 +0200, Arno Schuring wrote:
> Siard (on 2011-05-19 19:48 +0200):
> > I upgraded Squeeze to Wheezy.
> > After logging out of X (no matter which desktop or window manager)
> > the screen goes black, the monitor signal gets lost, its green
> > light turns to yellow. The only way to get out of this situation is
> > by pressing the reset button.
> What graphics card/video driver are you using?

ATi 9500 / R300.

> Does it also happen if you press ctrl-alt-f1 while logged in in X?

No, and then from the console I can power off the machine normally.

> Can you access the machine via the network?

This is a standalone machine.

> > So I tried a new installation of Wheezy, using the debootstrap
> > method as described in
> > www.debian.org/releases/stable/i386/apds03.html.en . But again, the
> > same phenomenon.
> > 
> > Any idea what the problem could be?
> I've had similar problems with my Ati r300-based card. It came down to
> incorrect refresh rates because of EDID (monitor probing) failures. On
> another machine (with Intel 915 chipset) I can't use kernel
> modesetting at all because the monitor lies about the resolutions it
> supports. There are kernel command line options to force a certain
> console mode/resolution, but they vary per driver.

Could you give the kernel command line options you have for your R300

> > Since mouse + keyboard did not work in X, I deleted /run, which
> > fixed that. Could this have something to do with it?
> Not likely. Also, look in the archives for a better solution (it has
> been posted somewhere in the last week), or search the Internet for
> "AllowEmptyInput".

Again, I did a new Wheezy install, it now includes the /run directory.
xorg.conf did not exist in /etc/X11, so I created one with these

Section "ServerFlags"
     Option "AutoAddDevices" "False"
     Option "AllowEmptyInput" "False"

But alas, still no working keyboard & mouse.
They _did_ work after deleting /run.

Reply to: