[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SWF (Adobe Flash) support


>From: Stanisław Findeisen <stf@eisenbits.com>
>To: debian-user@lists.debian.org
>Sent: Wednesday, May 18, 2011 2:59 AM
>Subject: SWF (Adobe Flash) support
>Is it possible to play Adobe Flash files from, for example, YouTube.com
>without non-free software?
>This is what I have:
>$ dpkg-query --list | grep -i -E 'flash|gnash|swf'
>ii  gnash                                0.8.4-3~lenny1             free
>SWF movie player
>ii  gnash-common                         0.8.4-3~lenny1             free
>SWF movie player - common files/librari
>ii  libswfdec-0.6-90                     0.6.8-1                    SWF
>(Macromedia Flash) decoder library
>ii  mozilla-plugin-gnash                 0.8.4-3~lenny1             free
>SWF movie player - Plugin for Mozilla a
>ii  swfdec-gnome                         2.22.2-2
>Tools to play SWF files (Macromedia Flash) o
>ii  swfdec-mozilla                       0.6.0-5
>Mozilla plugin for SWF files (Macromedia Fla
>However I am unable to play YouTube.com videos in Iceweasel 3.0.6. I
>even tried downloading one to the filesystem and running gnash on it,
>but it only displays a black rectangle. :-(
>What is the Debian recommended way, if any, to play SWF files?

You have a couple of options.  Have you tried  Linterna Magica? http://e-valkov.org/linterna-magica/   It is libre and it will help you play youtube with all free software.  It doesn't seem to work if the youtube is embedded in another web page.  They claim that it works on many flash websites, but I have had mixed results.

If you upgrade to squeeze, you can use Epiphany Browser to watch html5 video from youtube.com/html5   This doesn't seem to work 100% of the time, but maybe you will have better results.

The version of gnash in squeeze is quickly becoming outdated.  It hasn't worked for me in youtube lately (youtube always seems to be changing things)  and in other sites it doesn't work.  

You could build the latest gnash from source.  I did that when I was using gnewsense and it worked.  



Reply to: