[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Cannot output to external monitor

I'm having trouble getting anything to output from my X40 ThinkPad to
an external VGA monitor. Under X, `xrandr -q` outputs the following
regardless of whether or not the external monitor is plugged in:

   % xrandr -q
  Screen 0: minimum 800 x 600, current 1024 x 768, maximum 1024 x 768
  default connected 1024x768+0+0 0mm x 0mm
     1024x768        0.0*
     800x600        61.0

Pressing Fn+F7 and typing `xrandr --output VGA --auto` has no
effect...the external monitor remains totally blank.

The only way I can get anything to display externally is to plug the
external monitor in, then boot up. In this case the laptop screen
remains blank and the external monitor displays everything -- and
fuzzily, as it's outputting 1024x768 to a 1280x1024 display. And
no combination of alternating Fn+F7 key-presses and variations of
xrandr commands can get the laptop screen to not be blank. I had
to switch "Boot Display Device" in the BIOS from "ThinkPad LCD" to
"Analog (VGA)" or "Both" for this to work. I would've thought "Both"
would send output to both the external and internal displays -- and
I thought I had some recollection of that happening -- but my trials
this morning show the Laptop screen remaining blank. In any case,
having to re-boot the machine with the external monitor plugged in
doesn't seem like a reasonable solution.

Thanks for any help,


John Magolske

Reply to: