[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cannot umount: device is busy



On Thu, Apr 14, 2011 at 9:50 AM, T o n g <mlist4suntong@yahoo.com> wrote:
> On Thu, 14 Apr 2011 15:34:14 +0200, Jerome BENOIT wrote:
>
>>> I.e., there is no processes associated with the mount point any more,
>>> but I still can't umount the device. Moreover:
>>>
>>>    $ ps -eaf | grep knfs[d] || echo no found no found
>>>
>>> I.e., there isn't such task as knfsd in ps list. Why is that?
>>>
>>> Is there any way that I can kill all those kernel processes associated
>>> with the mount?
>>>
>> have you tried to force the umount ?
>
> Hi, thanks everyone for the replies.
>
> No, this is not a NFS share but a local dev mount, so stopping nfs or
> using force (in case of an unreachable NFS system) won't help.
>

sorta funny, i just went through this after debootstrap'ing a usb key.
so, besides the fuser -m, which you tried, lsof | grep <path>. and,
what did it for me, is that i forgot to unmount proc and sys before i
exited my chroot.
hth


Reply to: