[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: What happened to debian - does "stable" keep having any meaning?


Tom H wrote:
> On Mon, Mar 21, 2011 at 12:53 PM, Geronimo <geronimo013@arcor.de> wrote:
> > And yes of cause - I use LABEL and UUID in fstab for years ;)
> > 
> > If you read my writing carefully, you'll notice that I wrote, that grub
> > has problems with changing drive order.
> > 
> > The point is, in grub.cfg each partition is mentioned by (hd?, msdos?)
> > and hd? never matches. Last weeks I managed grub update errors by
> > manually editing grub.cfg (I know it should not be done, but it was the
> > only way for me to get the system running).
> Look at "/boot/grub/device.map". It sets up a correspondence between
> grub's hdX and devices in "/dev/disk/by-id/..." so it doesn't depend
> on the kernel's device names.

I tried to change that file, but I suspect, that nobody cares about that 
changes. I did that already about 6 weeks ago - and it did not change anything 
then, so I did not try it again.

> Run "grub-mkdevicemap" and "grub-install '(hdX)'" where "(hdX)"
> corresponds to the disk in "/boot/grub/device.map" on which you want
> to install grub.

That's what I usually try booting from debian installer disk using rescue 
mode. The point is, grub hangs after showing the "GRUB" black on white before 
displaying the menue.

> Furthermore, it's fine to have a rant and blame this or that for your
> problem but weren't you asked whether you wanted to chainload grub2
> from grub1 when you went through the upgrade? Did you choose that
> option? Did you test grub2 that way?

I beg your pardon. I remember that question a little bit, but its so long ago, 
that I really can't remember. I switched to squeeze, when debian anounced the 
feature freeze. I think that might be about one year ago or so.
That's why I don't understand the behaviour. Grub2 worked fine a really long 
time. Problems startet with squeeze becoming stable, or quite a bit before - 
not sure (may be about 6 weeks ago)

> I don't remember seeing a link (or, preferably, attachment) of your 
> boot.cfg and output of "/sbin/blkid | sort".

Ok, the latter is attached (well - just half of the disks), the former does 
not exists any more, cause I purged grub2

> I chose LILO (thanks, Boyd - beware of the inevitable questions!).

LOL - yes, I tried that too. liloconfig states, that it does not recognize my 
disks. Did I mention, that I use ext4?

> And it is actually possible to ask for GRUB-legacy.

I tried that too. Installation failed - and I didn't dig any further.
I can't believe, but having ubuntu installed to another partition, system now 
works fine - and I'm quite sure, that ubuntu uses grub2 too ...

kind regards

/dev/sda1: LABEL="StdRoot" UUID="7ce6540f-5ffe-445d-9bbf-d41652854700" TYPE="ext4" 
/dev/sda2: LABEL="boot" UUID="59c82698-6fcc-4512-a51c-261348d637da" TYPE="ext3" SEC_TYPE="ext2" 
/dev/sda3: LABEL="Deb_Rescue" UUID="b9ad85b7-d8b0-42f9-8c3a-c09a435cbe26" TYPE="ext4" 
/dev/sdb1: UUID="78c0ca79-1306-4250-9b7e-9e154c54eb50" SEC_TYPE="ext2" TYPE="ext3" 
/dev/sdb2: UUID="e2c0528e-4294-4b1b-bc0c-20819d0f5b6c" SEC_TYPE="ext2" TYPE="ext3" 
/dev/sdc1: UUID="129580e7-04cf-4700-82df-8ef9f6bd8fe7" TYPE="swap" 
/dev/sdc2: LABEL="Squeeze_User" UUID="44403194-a873-48ac-978c-b08a13c5d756" TYPE="ext4" 
/dev/sdd1: UUID="750773ee-f955-4f36-9c5c-1036adaeafb6" TYPE="swap" 
/dev/sdd2: LABEL="Squeeze_Var" UUID="55141d3b-4331-4f4a-b127-8ea77121a483" TYPE="ext4" 
/dev/sde1: UUID="2462a61a-8864-486b-820a-526a870a5452" TYPE="xfs" 

Reply to: