[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

events/0 and events/1 maxing CPU to 100%, related to wireless or eth0 on a T61 Thinkpad

Hello all,

I upgraded to Debian Squeeze a week ago on my Lenovo Thinkpad T61.
Starting earlier today, after no trigger that I could determine, my
CPU (an Intel Core 2 Duo) began maxing out on one or both cores to the
point where doing anything on the computer was incredibly choppy. I
initially thought that this might have something to do with running
compiz, which had been problematic a year ago, but the choppiness and
CPU maxing was observed after running "$ metacity --replace &" and in
the gdm login screen after a reboot.

I then thought that this might have something to do with my wireless,
which is frequently dropping connections, having difficulty
connecting, and from which kerneloops has been sending off kernel
errors for the past few days (my kernel is 2.6.32-5-686 from the
Squeeze repos). I use wicd as a wireless manager, however, killing the
wicd process and "# /etc/init.d/wicd stop" failed to help. This still
seems like a possible problem source, as I've seen some posts that
suggest that removing wicd entirely and rebooting solves the problem
even when stopping the process doesn't (such as in the post cited
below). However, as removing wicd eliminates what is currently my only
way of accessing the internet, I haven't tried that. Further, what I'm
about to describe seems to possibly contradict this being a wireless
issue (although it might still be).

I eventually found this post,
https://bbs.archlinux.org/viewtopic.php?id=88781, which suggests
running shutting down the eth0 interface ("# ifconfig eth0 down").
Shockingly, that actually worked, although the CPU still frequently
runs high. Turning eth0 back on causes the CPU to max out again. This
fix is imperfect since I'd like to be able to use the eth0 interface,
but it works at the moment.

Any idea what's going on here and/or how to fix it?


Kyle Barbour
(415) 238-9953
San Francisco, CA, USA

Reply to: