[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: editing /var/lib/dpkg/available

On Mon, 24 Jan 2011 22:36:45 +0000, Waqqas Dadabhoy wrote:

> I played around with Zimbra a while ago, but have removed it now. I get
> the following error whenever I use apt-get:
> warning, in file '/var/lib/dpkg/available' near line 8727 package
> 'zimbra-ldap':
>  error in Version string '6.0.8_GA_2661.DEBIAN5_64': invalid character
> in version number
> Since I won't be using Zimbra again, I am considering removing the
> Zimbra-related lines from /var/lib/dpkg/available. To me the
> hand-editing seems crude, is there a 'more clean' or 'recommended' way
> to get rid of the error?

"man dpkg" seems to point to "--clear-avail" as a mechanism to remove 
available packages (big disclaimer: better wait until someone in the know 
confirms this point)



Reply to: