[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Grub2 reinstall on raid1 system.

I have a raid1 based W/S running Debian Squeeze uptodate. (was
until ~7 days ago) There are 4 drives, 2 of which had never been
used or formatted. I configured a new array using Disk Utility from a
live Ubuntu CD. That's where I screwed up... The end result was the
names of the arrays were changed on the working 2 drives. IE: /dev/md0
to /dev/126 and /dev/md1 became md127. Strangely the md2 array which I
setup on the added drives remains as /dev/md2. My root partition is/was
on /dev/md0. The result is that Grub2 fails to boot the / array. I have
tried three REINSTALLING GRUB procedures from Sysresccd online docs
and many others GNU.org, Ubuntu etc. The errors occur when I try to
mount the partition with the /boot directory. 'Complains about file
system type 'linux_raid_member' This machine has worked for 3 years
flawlessly.. Can anyone help with this? Or point me to a place or link
to get this fixed. Google doesn't help... I can't find a
article/posting where it ended successfully.  
I have considered a full reinstall after Squeeze goes stable, since this
O/S is a crufty upgrade from sarge over time. But useless now..

TIA, Jack

Reply to: