[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problems installing on Dell R310

OK, this is a fun one.  I recently took delivery of a new server, a
Dell Poweredge R310

Intel Xeon X3440 quad core, 8GB RAM, etc. Storage is four 500GB
drives, hardware RAID1 so shows up as two 500GB drives to the system.
H/W controller is SAS1068e, Broadcom NIC, everything else is Intel

I want RAID10, so am doing s/w RAID0 during install using both
drives.  I have a non-raid /boot partition.  All f/s are ext3. Squeeze
and Lenny both want the non-free NIC drivers on a usb stick,
but otherwise both install without reported error.  For the purposes
of this question, I'm using Squeeze (but Lenny behaves the exact same
way, as does the most recent Ubuntu LTS)

No matter what combination of LVM, s/w RAID, no s/w RAID, no LVM or
whatever I use, GRUB refuses to boot the installed system.  Sometimes
I get a "GRUB"  prompt, but most of the time nothing at all past
POST.  No error messages are generated during the install process.  If
I boot a recovery console and try to manually install grub it
sometimes works, sometimes fails with an assortment of errors, the
googling of which gets me roughly nowhere.  Even if grub thinks it's
installed, on reboot it fails as above.

I've tried pinning grub to 'experimental', I've tried downgrading to
grub-legacy, I've added a rootdelay to let the RAID spin up, I've even
tried lilo!  No joy.

I did find a few mentions of older versions of grub having a few bugs
which relate to not booting off s/w RAID devices, but those bugs have
been fixed a while ago as far as I can tell.  But even if that were
the problem, installing with no RAID/LVM should work - which it

The most recent install attempt I've made had an empty /boot directory
(despite /vmlinuz.* etc symlinking into there).  I had to install a
previous kernel version before I got System.map, config, vmlinuz etc

in there, and manually running grub-update, grub-install, created
right-looking device.map, menu.lst and so on.  Now everything *looks*
right, it just doesn't *work*

Centos installs fine.  But I don't know rpm-based distros well enough
to do what I need to do down the line, and anyway - this is Debian for
goodness sakes!  I've installed loads of Debian systems just fine.

Any advice, pointers, useful cursewords or anything would be hugely
appreciated.  Two weeks now I've been going around in circles and I've
got a heck of a headache now!

Reply to: