[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Lenny backports installation of one package only

if you want to upgrade only iceweasel, then run 
apt-get install iceweasel/lenny-backports
by this, apt will try to install iceweasel from backports but will try to match its dependencies from lenny. it worked for me...


On Fri, Oct 8, 2010 at 12:28 AM, Bob Proulx <bob@proulx.com> wrote:
Russell Gadd wrote:
> I am trying to update my iceweasel via Lenny backports but it wants to also
> update my gnucash which I don't want. What am I doing wrong?
> I follow the instructions as follows:
> Add backports to sources.list (actually added a file to sources.list.d). It
> shows up in Synaptic repositories so looks ok

What is in your /etc/apt/preferences file?

What is the relative versions shown here:

 $ apt-cache policy gnucash

Because backports is set up with a repository pinning of
"NotAutomatic: yes" in the Release file it shouldn't be wanting to
upgrade your existing packages automatically.  Here is a reference.
Personally I set up /etc/apt/preferences as specified.


But if gnucash is newer than Lenny but older than backports then it
will fall into the case where it will want to upgrade to the newer
version in backports.


Version: GnuPG v1.4.10 (GNU/Linux)


Reply to: