[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cifs share is not mounted during boot

On 10/05/2010 05:11 PM, Klistvud wrote:
> Dne, 05. 10. 2010 13:51:39 je Eero Volotinen napisal(a):
>> try mount using ip address ? Are you sure that network is available
>> that time?
>> or add @reboot mount -a on cron crontab ?
>> -- 
>> Eero
> Actually, Eero's answer got me thinking that, at least in your case,
> perhaps a _netdev mount option in your stab could help?

With _netdev option I just get in the dmesg logs: [  141.008430] CIFS:
Unknown mount option _netdev
and the share is still not mounted.

Trying with just the IP instead of the dns name, also failed.

Then, I tried something more radical: I replaced /sbin/mount.cifs with
an ad-hoc shell script that I made, which just issues an echo test >
/tmp/test. So, after boot, I checked for a /tmp/test file but found
none. So, it looks like it's not got to do with some bad option, or the
network not being available or the credential file not being available
or something like that, but actually the binary used to mount cifs
shares is not even called during boot.

Any ideas?

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

Reply to: