[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: OpenIPMI in Lenny is mysterious to me.

On 09/22/10 03:04, Scott Ferguson wrote:
On 22/09/10 18:54, Dan Serban wrote:
# modprobe -a ipmi-si ipmi-devintf

which results with the following STDERR:

WARNING: Error inserting ipmi_devintf
Unknown symbol in module, or unknown parameter (see dmesg)

Then, in dmesg I see this:

[1012115.045436] ipmi message handler version 39.2
[1012115.048311] IPMI System Interface driver.
[1012115.048315] ipmi_si: Trying SMBIOS-specified kcs state machine at
i/o address 0xca2, slave address 0x20, irq 0
[1012115.227703] ipmi: Found new BMC (man_id: 0x000157,  prod_id:
0x003e, dev_id: 0x21)
[1012115.227703] IPMI kcs interface initialized
[1012115.235704] ipmi_devintf: Unknown symbol compat_alloc_user_space

# lsmod|grep ipmi returns:

ipmi_si                43628  0
ipmi_msghandler        38520  1 ipmi_si
If anyone has any experience with ipmi, I would certainly appreciate
some feedback.


No recent experience - and none configuring or installing it (IBM
in-house system) - so if that doesn't qualify, read no further.

Never, input is always appreciated.
My first thought would be to try load the modules separately:-
#modprobe ipmi-si
#dmesg | tail
#modprobe ipmi-devintf
etc.. for more clues
also try the same approach with the --show-depends or -f if you're game.

It seems that from another reply, it's the kernel I run, though I have tried inserting the modules in a different sequence seperately, I put the example in as I did simply for brevity, as I'm sure you can tell, I can get log winded. And again, same results.
Have you been through the IBM documentation?

No, but I've muddled through the intel documentation, it's excessive for a user. I do enjoy the IBM side of things, although a complete tangent now, I wish I had gone with them on my last server hardware purchase. I've RMA'd almost everything I've purchased from intel.
I'm presuming you've been through the projects bug tracker
and support requests for clues (also see their forums)

By sparse documentation are you referring to the man or the projects
pdf?  IBM have/had a lot of documentation - don't know how much is
available online (I don't have Red Book access here).

And yes, I've been through the BTS, nothing hits on the exact error or anything similar. When I was talking about documentation, I was referring to both man pages and examples, and not the spec. As one who hasn't delved deep into ipmi, all I had to really go from was the Documentation/ipmi.txt included with the kernel source which described linux's implementation of the standard. Which, in turn did not suggest anything close to my problem. As I understand it now, it doesn't need to as the kernel itself (as packaged for lenny) is now broken, but at the time that I wrote my OP, I was extremely lost as to what to look for.


Reply to: