[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Wesnoth 1.8 not finding campaigns

----Original Message----
From: Jordan Metzmeier [mailto:titan8990@gmail.com]
Sent: Wednesday, September 01, 2010 8:30 AM
To: debian-user@lists.debian.org
Subject: Re: Wesnoth 1.8 not finding campaigns

> Hash: SHA256
> On 09/01/2010 12:13 PM, James Zuelow wrote:
>> It looks like they changed the package names for the campaigns.
>> So what used to be wesnoth-trow is now wesnoth-1.8-trow.
>> Probably when you did the update, the old 1.6 campaigns were
>> uninstalled but the 1.8 campaigns weren't pulled down.  At least
>> that is what my machine wants to do.  
> Can you paste the output where your machine wants to do this? The
> "wesnoth" package declares depends on "wesnoth-1.8", which declares
> depends on "wesnoth-1.8-trow".
> I don't see why your machine would not want to install that package,
> provided you have either of those two meta packages.
> Regards,
> - --
> Jordan Metzmeier
Sorry Jordan, not anymore.  I just fixed it.

I typically run an `aptitude full-upgrade` on two Squeeze machines I have at home.  Two days ago wesnoth came down, and my desktop machine wanted to update wesnoth, but delete all of the campaigns without replacing them.  I figured that the campaigns just hadn't come down yet and aborted the upgrade.

Then after reading AG's message I ssh'd home and tried it again.  Aptitude wanted to do the same thing so I replied to the mailing list.  

After sending my reply I was still curious so I did an `apt-cache policy wesnoth-trow` and could see the new version as a candidate.  Then I checked and saw that the campaigns had been downloaded by cron-apt and were sitting in /var/cache/apt/archives.

So I tried an `apt-get dist-upgrade` and that updated the core wesnoth files AND the campaigns.

So there was some issue with aptitude not liking the campaigns, but apt-get resolved it.

I don't use the curses interface to aptitude, I just use it like apt-get with command line arguments so I'm 99.9% sure I didn't set a hold on the packages, etc.  But it works now.  :)

Reply to: