[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem with broken sudo package

I tried to upgrade sudo yesterday, but I had some errors. I can't send them, as mount is also broken so I can't transfer them to this computer. The error was something like:
  Can't create hard link to usr/var/archives/sudo (this may not be the exact path).
I decided to purge the package, and install it again, but this did not fix the issue.
My system is now in the following state:
Sudo can not be installed;
though aptitude thinks the package has been purged (after attempt to remove and reinstall) there are still some files called sudo on my system;
I tried removing files related to sudo, but can't (with rm or shred);
Since I broke sudo GDM will not work.
Please help me to figure this out, as I don't want to reinstall my entire system.
Also I will need very step by step instructions, as I am quite new to Linux and Debian.

__________ Information from ESET NOD32 Antivirus, version of virus signature database 5078 (20100501) __________

The message was checked by ESET NOD32 Antivirus.


Reply to: