[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

After recent upgrade, starting gdm shows "black" screen

I recently upgraded my Toshiba Satellite L45-S7409, running Debian testing (Squeeze). This morning when I started my laptop, the computer booted and I was able to use my GNOME desktop as usual. This afternoon, however, when I started my laptop, the screen went "black" a short moment after I saw: "Starting GNOME Display Manager: gdm". More specifically, the laptop screen's backlight is on and all I see is a single, white underscore at the top left of the screen (almost as if `gdm` failed to "take over" the display). The hard drive activity LED is flashing even with the "black" screen (all black except for the single underscore character), but the graphical login screen does not appear and typing on the keyboard has no effect on the display.

There was a change in the normal boot sequence. Normally after selecting a kernel from the GRUB menu, all of the text that is printed on screen when the kernel loads and all output from `init` is displayed in the same font and font size. Now after selecting a kernel, two lines appear quickly on screen (something about "ACPI") in the normal font and font size, the screen is cleared, and subsequent output (the word "kinit" and all output from loading the kernel and `init`) is displayed in a smaller font at 50 lines to a screen.

I thought that the problem was related to using a display mode that is not supported by the screen, so, while in maintainer mode, I tried regenerating `/etc/X11/xorg.conf` (`sudo dpkg-reconfigure -phigh xserver-xorg`). I also tried upgrading all packages to become fully up-to-date and re-installing `gdm`.

Has anyone experienced this or a related problem before and found a solution? What should I try doing?

Reply to: