[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: don't upgrade grub or grub-pc ! what's wrong with LILO ?

On Tue, Feb 02, 2010 at 10:47:17AM -0500, Stephen Powell wrote:
> On Tue, 2 Feb 2010 09:18:30 -0500 (EST), Tom Furie wrote:
> > One option would be to boot from a CD (installer, liveCD, whatever),
> > chroot into Debian and revert grub to an earlier version.
> As has been addressed in other recent posts, downgrading a package
> to a previous version once a newer version has been installed
> is unsupported and often difficult.  If there is a different package
> that performs the same function, it is usually easier to deinstall
> the problem package and install the alternative package in its place.
> Laying my personal biases aside and considering the problem as
> objectively as I can, I would recommend installing an alternate
> bootloader, if possible, rather than attempting to downgrade the
> existing bootloader.  But each user must decide for himself what
> works best in his situation.

In general I agree with you, but in this case it should be fairly
trivial since very little depends on grub, and the dependencies between
the versions haven't changed, to purge the current version and install
an earlier one. I know, for example that 1.98~20100126-1 still works.


Attachment: signature.asc
Description: Digital signature

Reply to: