[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Getting connected to Verizon 3G network

Hi guys

  I an still working on getting connected to the 3G network.  Actually
I am connected but I can't connect to the net.

Brief history. I am now using a D-Link DWA-556 PciE card. It has an Atheros AR5008 chip and I am using the mad-wifi ath5k driver code. I can connect to the Verizon MiFi , using wicd, get a ip address for the ath0 interface, and stay connected but, as mentioned above, I can't connect to the net.

Running route -n displays only the ath ip address. Without a route to the gateway I am stuck. Checking windows machines that 'can' connect
I see that they all get a different gateway addresses.  I can't add them
to the routing table because route won't allow any of them. Google has not found any posts/information about using the MiFi with Linux except
the ones I have posted here.

  The above is on testing.  I did have a 30 minute connection on stable
while using a Netgear Wg111v2 using the 64 bit driver from the Realtek site <http://www.realtek.com.tw/downloads/> for the RTL8187L used in this USB adapter. I used wicd and then copied all of the files over to testing, which I mainly use. After verifing that all the the conf files were the same, I tried connecting to the MiFi. I connected, got an IP address and when I then clicked anything else the machine crashed. By crashed I mead to froze completely and required a power off. I then tried using network-manager and it crashed the system as well. That is when I put in the D-Link card and it is not causing a crash. I went back to stable reluctantly, and was not able to connect again due to the fact that the gateway address, I stumbled upon the first time, was no longer the right one this time.

This leads to my question(s). How the heck do you find the gateway address? I thought that wicd/Network-Manager took care of that but there is no mention of gateway in the docs other then adding one in the .conf files.

I would rather stay away from ndiswrapper solutions, if I can. As the Verizon MiFi2200 Personal HotSpot is reported to be running on linux, I would hope that I can keep windows software out of the equation.

Any suggestions on any of the above are welcomed. I really would like to get this beast working.

Thanks and a Happy New Year to you all.


Reply to: