[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[SOLVED] Permission denied when changing fan speed on T23 (Lenny)

I forgot to mark my previous reply to this thread solved, silly me :)

I've also written a little script for the benefit of those who may have
a similiar problem in the future and find this via the archives or by
google. Due to the triviality of this script, I'm declaring it to be
public domain.

   ASCII Ribbon Campaign Against  ( )   Brian Ryans
      HTML E-mail and V-cards      X    BrianLRyans@gmail.com
        www.asciiribbon.org       / \   GPG Public Key 0xC11213D0
 Key Fingerprint: 8B2A 54C4 E275 8CFD 8A7D 5D0B 0AD0 B014 C112 13D0
#!/usr/bin/env sh
# Public-domain fan control script for IBM Thinkpad laptops. Tested on a T23.
# Very kludgy, use at your own risk, may contain bugs, no warranty, etc etc.

declare ibmfan='/proc/acpi/ibm/fan'

display_status() {
    speed=$(grep ^speed $ibmfan | cut -d: -f2 | tr -d '[:space:]')
    level=$(grep ^level $ibmfan | cut -d: -f2 | tr -d '[:space:]')
    echo "level $level at ${speed}rpm"

# user entry point
[ -z "$1" ] && display_status

case "$action" in
    0|1|2|3|4|5|6|7)    echo "level $action" > $ibmfan ;;
    f*|m*)		echo "level full-speed" > $ibmfan ;;
    a*)			echo "level auto" > $ibmfan ;;

Attachment: signature.asc
Description: Digital signature

Reply to: