[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Permission denied when tweaking various /proc knobs (Lenny)

I am attempting to adjust brightness via '/proc/acpi/ibm/brightness',
but I get permission denied if I do it via sudo -- I have to su to root
in order to do the adjustments. Log at [1].

bryans@esterhazy:~$ sudo echo up > /proc/acpi/ibm/brightness
bash: /proc/acpi/ibm/brightness: Permission denied
bryans@esterhazy:~$ su
esterhazy:/home/bryans# echo up > /proc/acpi/ibm/brightness
/* Display brightness increases */
[end 1]

I am in my /etc/sudoers file with all permissions. My /etc/sudoers file,
with comments stripped, is at [2].

Defaults    env_reset
root    ALL=(ALL) ALL
bryans  ALL=(ALL) ALL
[end 2]

My sudoers seems alright as I can execute other privileged commands with
no difficulty, just not mess around with the files in /proc (those few
I've tried)

I don't think it _can_ be a permissions issue, as by my understanding,
absolutely no permission checks are applied to root by userspace --
though correct me if I'm wrong.

I tried to "sudo echo h > /proc/sysrq-trigger", and again was denied.
This led me to look in "$linux/kernel/sysrq.c", but I found nothing
useful in determining why I can't do this using sudo.

I'm left to several possibilities:

1.  I'm misunderstanding some documentation somewhere (PEBKAC)
2.  sudo cannot allow me to do this, possibly due to restrictions
    elsewhere in the kernel [3]
3.  I'm able to do this, but I'm just not looking in the right place for
    how to enable it

[3] Highly unlikely, by my knowledge.

   ASCII Ribbon Campaign Against  ( )   Brian Ryans
      HTML E-mail and V-cards      X    BrianLRyans@gmail.com
        www.asciiribbon.org       / \   GPG Public Key 0xC11213D0
 Key Fingerprint: 8B2A 54C4 E275 8CFD 8A7D 5D0B 0AD0 B014 C112 13D0

Attachment: signature.asc
Description: Digital signature

Reply to: