[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

squeeze, amd64 and X problems, perhaps nvidia related

Some experiences with squeeze on a laptop.

0) The problems below are (at least for me) tricky to debug. I'm
asking for hints
on how to obtain more information about what goes on so that I can make a
formal bug report.

1) I'm experiencing some bugs with X on a laptop, either at wakeup or suddenly
in the middle of a seemingly normal session. It does not really lock,
but it totally
borks my screen by replacing tiles of the original screen content on
other places
of the screen area so it does look somewhat of a caleidoscope image. The
replacing may continue for 5-10 seconds and the limits between different tiles
are somewhat fuzzy though. Sometimes the computer becomes extremeley
slow and the cursor moves now and then in short steps. On one occasion I
think it actually did lock, i.e. I think  that X did not accept any
input, and then I
had to shutdown by the power button.

2) In some instances I have been able to shutdown the computer by
painstakingly slow X moves. When it reboots everything is normal.

3) On other occasions I have been able to switch to a virtual terminal
where no image/text is shown. Nevertheless I have been able to log
in blindly as root and request a reboot.

4) A couple of times the same stuff has happened at wakeup. Interestingly,
after closing the lid, waiting a short while so that it goes to sleep again, and
opening the lid, the computer made a normal wakeup!

5) Further, the problem of non-existant screen output on virtual consoles
have occured at several other times. Apparently, the VTs do in fact
function but it without text it is difficult to use them.

6) The problems occur on my Dell M2400 laptop on which I run Debian
for amd64. I started out with lenny but several weeks ago I upgraded to
squeeze in order to get later versions of some packages.
I run nvidia stuff from sid. The problems were present both with nvidia
version 185.18.36-2. and the current 194.42-3. I am using kde and the
2.6.31 kernel
from sid from which uname -a reports:

Linux laptop 2.6.31-1-amd64 #1 SMP Sat Oct 24 17:50:31 UTC 2009 x86_64 GNU/Linux

but I have seen the problem with the squeeze kernel 2.6.30 as well.

The M2400 has a nvidia graphics card of type  FX370M card for which
lspci reports:

01:00.0 VGA compatible controller: nVidia Corporation Device 06fb (rev a1)

The nvidia packages installed are:
i   nvidia-glx                                       - NVIDIA binary Xorg driver
i   nvidia-glx-ia32                               - NVIDIA binary
driver 32bit libs
i   nvidia-kernel-2.6.30-2-amd64       - NVIDIA binary kernel module
for Linux 2.6.30-2-amd64
i   nvidia-kernel-2.6.31-1-amd64       - NVIDIA binary kernel module
for Linux 2.6.31-1-amd64
i A nvidia-kernel-common                 - NVIDIA binary kernel module
common files
i   nvidia-kernel-source                     - NVIDIA binary kernel
module source
i   nvidia-settings                              - Tool for
configuring the NVIDIA graphics driver
i   nvidia-xconfig                              - The NVIDIA X
Configuration Tool

7) With lenny there were not any of these problems. In order to get
X working and sleep/hibernate I had to use a backported 2.6.30 or 31
kernel from backports, and the nvidia drivers from sid. This suggests
that the problems I'm experiencing now are are related to the squeeze


Reply to: