[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

eSATA woes

I've been running a RAID1 on Firewire for years, but I really want SMART
monitoring and SATA drives (and enclosures) keep getting cheaper. I'm
running on older hardware with only PCI slots, no PCI-E or PCI-X, so I
picked up a PCI SATA card with two SATA ports and two eSATA ports. It shows
up in lspci like this:

0001:10:12.0 RAID bus controller: Silicon Image, Inc. SiI 3124 PCI-X Serial ATA Controller (rev 02)

It's automatically detected and the sata_sil24 module loads. The problem
comes when I try to connect an eSATA enclosure. I get console messages
immediately upon connecting an eSATA drive, but it goes through a cycle of
trying to establish a link, timing out, resetting, retrying, etc. a few
times before finally giving up.

I've tried three different enclosures now, only one of which uses eSATA
multiport, and they all exhibit the same behavior. Two of the enclosures
also support USB, and work fine when plugged into a USB port. This isn't a
viable long-term solution, however, since it still doesn't get me SMART
monitoring and, much more importantly, the old hardware only supports USB
1.1 thus runs the disks incredibly slowly.

Can anyone point me to a specific enclosure that is known to work well
under Linux? Could it be a problem with the card rather than the
enclosures? How can I fix this?


Reply to: