[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Anybody tried installing squeeze on a PowerPC Mac recently?

Rick Thomas wrote:

Installing squeeze on a G4 PowerMac from the "sid d-i" daily "Businesscard" CD.

All seemed nominal during the install.  But after the reboot,
the login screen did not appear.  I was left sitting at a text
console.  In fact, it appears that gdm and nearly all of the
gnome-desktop-environment task is missing. (And yes, I did check
"desktop" during the tasksel phase of the installation!)

When I logged in and typed "startx" I was left with a black

For what it's worth, an i386 install at about the same time went flawlessly.

This is repeatable. I've tried it with two different dailys. And with Businesscard and Netinst CDs.

I just updated Lenny to Squeeze on an i386 and had the same problem as far as gdm being missing. It came up in the text console so I started fiddling with the xorg.conf file. It seems like 3/4 of the Debian installs I've done have needed such fiddling. I fired up X and also got a black screen. I finally realized gdm was missing so I used aptitude to install it. It came up in the GUI okay after that. The one item I have to had is that postgresql and a couple of related packages threw out errors when aptitude ran. I've tried re-installing them with no luck. Postgresql appears to be running and I haven't seen anything complaining about it. Oh, I did notice that only postgresql 8.3 was set up in init.d. I disabled it and enabled 8.4. No change though.

Reply to: