[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: AVAHI cupsd warning


On Sun, 2009-11-08 at 09:14 -0400, Paul Cartwright wrote:
> I was browsing my /var/log files this morning, and happened to tail messages. 
> I found these:
> Nov  7 14:22:05 paulandcilla cupsd[23014]: *** WARNING *** The program 'cupsd' 
> uses the Apple Bonjour compatibility layer of Avahi.
> Nov  7 14:22:05 paulandcilla cupsd[23014]: *** WARNING *** Please fix your 
> application to use the native API of Avahi!
> Nov  7 14:22:05 paulandcilla cupsd[23014]: *** WARNING *** For more 
> information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=cupsd>

The version of cups provided in Lenny[1] uses a compatibility layer of
Avahi (package libavahi-compat-libdnssd1).
Therefore, Avahi is complaining/suggesting the developer [of cups], to
use avahi libraries directly.

FYI, this has been fixed in the version of cups in Testing  (it now uses
Avahi's native library: "libavahi-client3")

> # dpkg --list cups
> ii  cups           1.3.8-1+lenny6 Common UNIX Printing System(tm) - server
> so, I guess my question is, do I need to change anything?
> running lenny, up-2-date

This message is intended to the developers (i.e it isn't intended to you
[the system admin]).
You can safely ignore this message. 



[1] http://packages.debian.org/lenny/cups
[2] http://packages.debian.org/squeeze/cups

Reply to: