[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Lost my window manager

On Fri, 6 Nov 2009 08:16:40 +0100
Jochen Schulz <ml@well-adjusted.de> dijo:

> > Unfortunately, the entire Gnome panel is gone. Clicking on where things
> > are supposed to be in the panel does nothing.
> Is the panel gone or is it empty?

That is a good question, but I cannot answer it. I like my desktop as
clean and austere as possible. Tht is why I set it to display no icons
for things in the ~/Desktop folder. I also use just a light solid color
background, and I set the panel to the same thing and transparent. I
also removed the bottom panel. So all I normally see is the Word
"Applications," "Places," System," and the rest of the items on the
panel. None of them appear, so I am asuming the panel is not running.
But if it was empty I would see the same blank spot at the top of the
> > Windows have no title bar
> > or icons in the corner to minimize or maximize them The keyboard works,
> > but I cannot launch a terminal because I have forgotten the secret
> > keyboard shortcut to launch a terminal.

> Alt-F2 should spawn a "Run dialog". Use that to run the missing
> programs:
> metacity
> gnome-panel (if it is completely gone)

Alt-F2 does nothing. Just now I tried it on the computer I am using to
type this (a desktop with Ubuntu Intrepid), and Alt-F2 does bring up
the Run dialog box. So Alt-F2 is also broken in my Debian testing. 
> > The only way I know how to do
> > it is Applications > Accessories > Terminal, but there is no panel so I
> > can't click on Appplications. I did get to a command line with
> > Ctrl-Alt-F1, but I was unable to do anything constructive for failure
> > to know what the window manager is called or how to restore it.
> That wouldn't have worked anyway, since you have to start X programs in
> an X environment.

I aldready discovered that. But at least it is one way I can get a
command line, in case there is something else that I can do without
being in an X environment.

> > I also note that, although I logged in as myself, some of my display
> > preferences were not honored. For example, I had Gnome set not to
> > display any icons at all on the dekstop. I wanted a dekstop utterly
> > devoid of anything except the Gnome panel. However, now all the items
> > contained in the Desktop folder appear on the screen.
> Did you look for strange messages in /var/log/syslog? It appears
> something is seriously broken. Obviously, what you experienced shouldn't
> happen.

I rebooted  and then I read through the entire file starting at the
point where I rebooted, using "nano /var/log/syslog." When I finished I
turned to the desktop computer to write this e-mail. Just now I wanted
to move the cursor up so I could see the end of one suspicious line,
only to discover that nano has locked up while I was typing this. I
just used Ctrl-Alt-Del to reboot.

> > I am just about to give up and go back to Ubuntu. I had said at the
> > outset of my foray into Debian that I would give it a week, but it has
> > become apparent that I do not have the technical expertise to run
> > Debian.
> The symptoms you describe shouldn't happen in either Debian or Ubuntu.
> And if they happen (and you don't know how to work around them), you're
> screwed with both distros. :-/

While waiting for someone to offer some suggestions I tried the Karmic
x86_64 live CD. I was able to configure my bluetooth mouse without too
much difficulty, but it kept disconnecting every ten minutes or so. I
might be able to fix it if I actually installed Karmic, but I am not
impressed. I first got this mouse back in the days of Hardy and it
worked perfectly all the time. So did my cell phone and my headphones. 

I was also not impressed by the fact that Shutdown is as broken in
Karmic as it has been on all versions of Ubuntu since I first installed
it on my T61 when it was brand new. It shuts down to a blinking cursor
at the top loeft of a black screen, but the LEDs are still lit up. I
have to use the power switch to turn it off. At least with Debian
testing I could shut down the computer properly.

> I think I would try moving the Gnome-related files (.gnome2/,
> .gnome2_private) in my $HOME out of the way and cnfigure it from
> scratch.

An excellent suggestion. Sadly, it changed nothing. That is, I used
Ctrl-Alt-F1 to get to a command line and then I used mv to rename them
by appending .old. Then I rebooted. But the display still shows no
panel and I still see the icons for my Desktop folder. I can click on
the icon for "JJJ's Home" and it will open a Nautilus browser window.
In the browser window I can select files, and I can use the keyboard to
rename them. But if I try to move the browser window I cannot because
dragging on the title bar does not work. However, I note that
new .gnome* folders were created when I rebooted.

I also tried changing the session to failsafe-GNOME, but that got me a
completely empty screen.

While poking around I discovered that if I right-click on the desktop I
have the option to create a launcher. I created one for gnome-terminal,
and it worked. Yay! I now have a way to launch a terminal, although it
is running in the broken desktop.

In the terminal I typed "gnome-panel" and my panel appeared! Then I
opened a new tab and typoed "metacity," and the window manager was
back! Yay!

However, if I close the terminal window it stops the processes, and the
panel and the window manager disappear. I find it interesting that the
icons for the Desktop folder items still appear on the desktop, even
though I had set up the desktop to be empty. Something in my personal
preferences is not getting loaded.

Slowly I am making progress. At least now I have a way to get the
window manager and Gnome panel back. 

Thanks for the suggestions and patience!

Reply to: