[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How do I make udev give me /dev/lp0 ?

Mark Weyer wrote:
> Please CC me, I am not subscribed.
> I am using lenny on an amd64 with the standard kernel.
> The short question is in the subject. The long version follows.
> When trying to use my printer, I installed cups and foomatic, because the
> package descriptions suggested that I needed to. However, foomatic did not
> know the printer model and thus configuration of cups failed. Then I just
> tried
>   cp bla.ps /dev/lp0
> because I felt that it "should" work. It did.
> So I happily uninstalled cups, foomatic and all the bloat that they pull
> in as dependencies. The problem: Next time I tried (after a number of
> reboots), /dev/lp0 was gone.
> The standard kernel (which I use) uses udev and if I understand the latter
> correctly, it should always give me (in /dev) the devices which are
> physically present. As my parallel port is always present and there is no
> way to detect whether anything is conected to the far end, why is there no
> /dev/lp0 by default? Or at least when there is something at the far end?
> How do I get /dev/lp0 back?

Does the device appear if you run as root 'modprobe parport'? If so, you
just need to make sure this module is always loaded. Easiest way to do
that is add a line containing 'parport' to the file /etc/modules.

"His eyes were cold.  As cold as the bitter winter snow that was falling
outside.  Yes, cold and therefore difficult to chew..."


Reply to: