[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

debian lenny serial console garbage with a cyclades


	I have a few dell poweredge servers (with debian lenny) connected
through a serial port with a cyclades console server.

	I can log in into the cyclades and connect to one of this server. Then,
I can see the boot of the server and so on.

	The problem I have is that during the boot, while loading drivers, when
it loads serial driver, I get a lot of garbage and console doesn't work
until login (that is, I can't see messages displays by init.d scripts).
When login is run, it works again without any problem.

	The garbage I get is:

[    2.982482] Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ
[    2.991704] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a NS16550A
[    2.998232] serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
Debian GNU/Linux 5.0 felis116 ttyS0

felis116 login: 

	Then, I can't see anything until login is reached.

	The cyclades configuration for this port is (I configured it as a
Console (Telnet) port):

s26.tty	ttyS26
s26.alias felis116
s26.issue \r\n     Welcome to Console Server Management Server %h port S
%p \n\r\n
s26.speed 115200
s26.datasize 8
s26.stopbits 1
s26.parity none
s26.flow none
s26.dcd 0

	any idea?

Angel L. Mateo Martínez
Sección de Telemática
Área de Tecnologías de la Información       _o)
y las Comunicaciones Aplicadas (ATICA)      / \\
http://www.um.es/atica                    _(___V
Tfo: 868887590
Fax: 868888337

Reply to: