[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Thinkpad Touchpad no longer works [Solved]

On Sat, Oct 17, 2009 at 16:19:36 +0100, Barry Samuels wrote:
> On 17/10/09 15:12:35, Florian Kulzer wrote:
> > It seems that you have an outdated 50-udev.rules file in
> > /etc/udev/rules.d/, which means that the up-to-date file in
> > /lib/udev/rules.d/ is ignored.
> > 
> > Quoting from udev's NEWS.Debian.gz:
> > The default rules files have been moved to /lib/udev/rules.d/ and
> > /etc/udev/rules.d/ is supposed to contain only generated files or custom
> > directives. (starting udev version 0.140-1)
> Florian
> You are so right! Removing that file has cured the problem.
> All that file had in it was:
> KERNEL=='rtc0',		SYMLINK+="rtc"

It seems a bit strange to me that an older version of 50-udev.rules
would only contain one line. (I just looked at this file for Lenny, udev
0.125-7+lenny3; it has 108 lines.) Did you check your filesystems and
the SMART information of your hard drive recently?

> I can't honestly say now whether I put that there or not. Thank you so 
> much for your help.

I am glad to hear that the problem is solved. It might be a good idea to
check if you have other duplicate rules files on your system. The
following bash one-liner should list all files in /etc/udev/rules.d/
that also exist in /lib/udev/rules.d/:

for FILE in /etc/udev/rules.d/*; do [[ -a /lib/udev/rules.d/${FILE##*/} ]] && echo $FILE; done

Regards,            | http://users.icfo.es/Florian.Kulzer
          Florian   |

Reply to: