[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Ubuntu noninteractive aptitude mysql install

On Sat, Oct 10, 2009 at 4:57 PM, Daniel Burrows <dburrows@debian.org> wrote:
> On Tue, Oct 06, 2009 at 09:42:57AM -0700, Chad Woolley <thewoolleyman@gmail.com> was heard to say:
>> When scripting an aptitude install of mysql on ubuntu, how can I avoid
>> blocking at aptitude's interactive root password prompt?
>  aptitude doesn't prompt for a root password at the command line.
>> I tried the following, but it doesn't work on when I run it on a clean
>> EC2 image:
>> http://github.com/thewoolleyman/rails/blob/master/ci/setup_rails_dependencies.rb#L26
>> Maddeningly, it works fine when I immediately do the same thing again.
>  You're becoming root like this:
>    $ run "sudo su -c 'echo \"#{pw_file}\" > /var/cache/debconf/passwords.dat'"
>  It sounds like you're getting a prompt from sudo?

No, that's not it - I have nopasswd set in sudoers.  All other
commands I run via sudo run fine.  It is just the mysql server install
that hangs.

Reply to: