Re: Failed to install libmysql library for MYSQL client
On Thu, Sep 24, 2009 at 05:17:20PM +0530, Dinesh Lohan wrote:
> I am using TS-7300 board having Debain Linux version 2.86
2.86 is not the version of Debian (or Linux). It is the version of
/sbin/init. Debian is probablt 4.0 (Etch) or 5.0 (Lenny).
> and Installed
> mysql client but when trying to
> install library for mysql client using apt-get install libmysqlclient15-dev
> not working.
> root@ts7300:apt-get install libmysqlclient15-dev
> Reading package lists...Done
> Building dependency tree... Done
> you might want to run 'apt-get -f install' to correct these:
> The following packages have unmet dependencies:
> binutils:depends:Lib6(>=2.7-1) but 2.3.6.ds1-13etch4 is to be installed
> libc6:depends:tzdata but it is not going to be installed
$ rmadison libc6
libc6 | 2.3.6.ds1-13 | etch-m68k | m68k
libc6 | 2.3.6.ds1-13etch9 | oldstable | amd64, arm, hppa, mips, mipsel, powerpc, s390, sparc
libc6 | 2.3.6.ds1-13etch9+b1 | oldstable | i386
libc6 | 2.7-18 | stable | amd64, arm, armel, hppa, i386, mips, mipsel, powerpc, s390, sparc
libc6 | 2.9-25 | testing | amd64, armel, hppa, i386, mips, mipsel, powerpc, s390, sparc
libc6 | 2.9-26 | unstable | amd64, armel, hppa, i386, mips, mipsel, powerpc, s390, sparc
libc6 | 2.10.1-0exp1 | experimental | amd64, armel, powerpc
You seem to have an Etch version of libc6 (glibc) but you attempt to
install a package that requires the Lenny version of it.
Upgrading the system to Lenny may be a good idea, but then again, it may
not be a possible alternative for you.
In addition to the question about sources.list , what is the output of:
Tzafrir Cohen | firstname.lastname@example.org | VIM is
http://tzafrir.org.il | | a Mutt's
email@example.com | | best
ICQ# 16849754 | | friend