[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-get error message seems contradictory

On Sat, Sep 05, 2009 at 12:03:37PM +0800, Gero Putzar wrote:
> Hi,
> I get the following error message from apt-get:
> ---snip---
> The following packages have unmet dependencies:
>   libc6-i386: Breaks: lib32asound2 (<= 1.0.20-2) but 1.0.16-2 is to be
> installed
>               Breaks: lib32gcc1 (<= 1:4.4.0-6) but 1:4.3.2-1.1 is to be
> installed
> ---snap---
> I don't understand it. I read it like that:
> libc6-i386 needs lib32asound2 version 1.0.20-2 or lower.
> But for whatever reason, apt-get wants to install Version 1.0.16-2 of
> lib32asound2.

It says libc6-i386 *breaks* lib32asound2 <= 1.0.20-2. This means that
the version of lib32asound2 has to be higher than 1.0.20-2 for it to not
be broken. Lenny does not have a version higher than that, hence the
dependency problem.


Attachment: signature.asc
Description: Digital signature

Reply to: