[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dot matrix printer unicode question







On Sat, 1 Aug 2009, Osamu Aoki wrote:

Hi,

Jude, relax and take your time to read and

It is recommended not to use top posting on Mailing list. (I reordered)

On Sat, 1 Aug 2009, Osamu Aoki wrote:
You are very unclear what you mean by "real dos computer".

On Sat, Aug 01, 2009 at 02:04:20AM -0400, Jude DaShiell wrote:
By real dos computer I mean a different machine with msdos 6.22 installed
on it that was connected to the printer through its parallel port and the
file was copied to a floppy disk and printed from that floppy disk on the
other machine.  The other machine hasn't enough resources to install
windows or Linux, so it's a real dos machine.  When I tried this on
debian I tried: cat biglots.txt >/dev/lp0 and lpr biglots.txt and lp
biglots.txt I didn't try piping the cat through lp or lpr.  The 13 line
file was a text file I made with ex if memory serves.

So far, I understand but you did not answer the rest of the mail.

Are you doing:

debian $ cat somefile.txt |lpr

dos>     cat somefile.txt > PRT:

or used some DOS full screen application to print via menu dialog.

(I forgot DOS device name for parport.)

This is important.

I have a printer queue set up which allows lpr and lp both to
print garbage last time a sighted person took a look dollar signs
question marks and very long lines of text were being printed.

If you are using DOS full screen application to print via menu dialog,
text is processed to fit to printer protocol by your DOS application.

If you did not configure lpr right, data is directly sent to printer.
UTF-8 character makes this situation worse because printer assumes asii
with some escape sequence as expected input.

I recommend you to use CUPS which set up printer eaily.  If you have
problem with some UTF-8 chracters, you need to convert text with a2ps
etc. to ps file.

This is a grocery list with one item per line.

Please read following and CUPS documentation for more:

http://www.debian.org/doc/manuals/debian-reference/ch06.en.html#_the_print_server_and_utility
http://www.cups.org/

Have you took time to read at least some of these?

Anyway, you really need to configure printer system.

There is no one line answer for it.

Osamu


I did a couple things by way of configuration. I used lynx http://localhost:631/printers to set the KX-P1123 as the default device and set my user account as an allowed user then I got out of there. Next I tried cat biglots.txt | lpr and got about what sounded like six lines to print. Next I tried cat biglots.txt | lp and got what sounded like 10 lines to print. A little later this weekend I'll find out what actually printed out. This is getting interesting.


Reply to: