[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


simon h skrev:
I wonder why Debian needs three versions of the GCC compiler: 4.1, 4.2,
and 4.3? Shouldn't one be enough? Is it because the compiler has no

I think that is the reason, yes. I also think that lack of manpower is the reason there are not even more (older) versions of gcc in debian.

At <http://gcc.gnu.org/gcc-4.4/changes.html>, you can see that there are changes between versions that can break certain programs. I was recently asked for advice by someone that needs a 3.x version of gcc.

(For completeness: I will suggest debootstrap/schroot for running gcc3.X without affecting his current installation.)

/ johan

Reply to: