[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Failure to boot after failed resume from s2something

I've a puzzling failure to boot.  Error messages have to be copied
over by hand, so apologies if there are typos. The boot process seems
normal past cryptsetup's request for the password. The first sign of
trouble reads
mount: mounting /dev/mapper/[name of my swap partition] on /root failed: no such device

Next, initramfs appears to run /scripts/local-top and
/scripts/local-premount successfully. Maybe. Kinit goes for a
normal boot after pondering manual.  Then comes
Begin: running /scripts/init-bottom
mount: mounting /dev on /root/dev failed: No such file or directory.

There are similar failures re. sys and /proc. Also the message:
Target filesystem doesn't have /sbin/init

At this point, I am dumped into busybox:
but I haven't managed to figure out what to fix or how to fix it.

The problem first appeared when trying to resume from s2ram (or was it
s2both?) under a home-compiled vanilla kernel. Purging and
reinstalling that kernel did not change the problem. A home-compiled
kernel from 2.6.29-4 vanilla sources has worked fine throughout. I
tried another kernel, compiled from the basic config-2.6.29-4 that
works, but from Debian 2.6.30-2 sources, and it fails in exactly the
same way.

Googling the error messages has not produced anything I could
figure out. I'm stumped. Clues will be gratefully accepted.

GPG key 1024D/99421A63 2005-01-05
EE51 79E9 F244 D734 A012 1CEC 7813 9FE9 9942 1A63
gpg --keyserver subkeys.pgp.net --recv-keys 99421A63

Attachment: signature.asc
Description: Digital signature

Reply to: