[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: KDE is now broken (Fwd: Heads-up: KDE4 hitting testing tonight (UTC) )



H.S. wrote:
> Boyd Stephen Smith Jr. wrote:
>> In <20090521174259.GA7739@cat.rubenette.is-a-geek.com>, lee wrote:
>>> I refuse to run a
>>> mysql-server just to get KDE installed. It's already bloated more than
>>> enough. I'm not using the applications that would require the
>>> mysql-server anyway.
>> Then don't install those applications.  Problem solved.
> 
> Which ones are those? I also got mysql with my KDE upgrade but would
> like to get rid of it.


I removed mysql-server-5.0 and KDE appears to be working fine so far.
Here is what aptitude actually did:

$> sudo aptitude purge mysql-server-5.0 kontact libkcal2b

Reading package lists... Done


Building dependency tree


Reading state information... Done


Reading extended state information


Initializing package states... Done


Reading task descriptions... Done


The following packages are BROKEN:


  akonadi-server karm kdepim-kfile-plugins kdepim-kio-plugins
kitchensync ksync libkdepim1a

The following packages will be REMOVED:


  google-gadgets-common{u} google-gadgets-gst{u} google-gadgets-qt{u}
google-gadgets-xul{u} kontact{p} libeet1{u} libggadget-1.0-0{u}
libggadget-qt-1.0-0{u}
  libkcal2b{p} libkde4-ruby1.8{u} libplasma-ruby{u} libplasma-ruby1.8{u}
libqedje0{u} libqt4-ruby1.8{u} libqtruby4shared2{u} libqzion0{u}
libsmokekde4-2{u}
  libsmokeplasma2{u} libsmokeqt4-2{u} mysql-server-5.0{p}
plasma-scriptengine-python{u}

0 packages upgraded, 0 newly installed, 21 to remove and 3 not upgraded.


Need to get 0B of archives. After unpacking 116MB will be freed.


The following packages have unmet dependencies:


  kdepim-kfile-plugins: Depends: libkcal2b (>= 4:3.5.9) but it is not
installable
  kdepim-kio-plugins: Depends: libkcal2b (>= 4:3.5.9) but it is not
installable
  ksync: Depends: libkcal2b (>= 4:3.5.5) but it is not installable
  libkdepim1a: Depends: libkcal2b (>= 4:3.5.9) but it is not installable
  akonadi-server: Depends: mysql-server but it is not installable
  karm: Depends: libkcal2b (>= 4:3.5.9) but it is not installable
  kitchensync: Depends: libkcal2b (>= 4:3.5.9) but it is not installable
The following actions will resolve these dependencies:

Remove the following packages:
akonadi-server
kaddressbook
kaddressbook-plugins
karm
kdepim-kfile-plugins
kdepim-kio-plugins
kitchensync
korn
ksync
libkdepim1a

Score is 382

Accept this solution? [Y/n/q/?]
The following packages will be REMOVED:
  akonadi-server{a} gnokii-common{u} google-gadgets-common{u}
google-gadgets-gst{u} google-gadgets-qt{u} google-gadgets-xul{u}
kaddressbook{a}
  kaddressbook-plugins{a} karm{a} kdepim-kfile-plugins{a}
kdepim-kio-plugins{a} kitchensync{a} kontact{p} korn{a} ksync{a}
libdbd-mysql-perl{u} libdbi-perl{u}
  libeet1{u} libggadget-1.0-0{u} libggadget-qt-1.0-0{u} libgnokii4{u}
libkcal2b{p} libkde4-ruby1.8{u} libkdepim1a{a} libnet-daemon-perl{u}
libplasma-ruby{u}
  libplasma-ruby1.8{u} libplrpc-perl{u} libqedje0{u} libqt4-ruby1.8{u}
libqtruby4shared2{u} libqzion0{u} libsmokekde4-2{u} libsmokeplasma2{u}
libsmokeqt4-2{u}
  mysql-client-5.0{u} mysql-server-5.0{p} plasma-scriptengine-python{u}
0 packages upgraded, 0 newly installed, 38 to remove and 3 not upgraded.
Need to get 0B of archives. After unpacking 148MB will be freed.
Do you want to continue? [Y/n/?]


and then I continued by pressing Y.

Regards.



-- 

Please reply to this list only. I read this list on its corresponding
newsgroup on gmane.org. Replies sent to my email address are just
filtered to a folder in my mailbox and get periodically deleted without
ever having been read.


Reply to: