[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem compiling custom kernel on debian

Divick Kishore:
>> On Tue, Apr 21, 2009 at 1:22 PM, Jochen Schulz <ml@well-adjusted.de> > wrote:
>> Your problem is most probably unrelated to your building a kernel. Take
>> a look into /var/log/syslog and/or dmesg output. You will probably find
>> messages about hard disk errors. Post them here if you have trouble
>> interpreting them.
> Strangely this starts off when I try to run make-kpkg. I don´t see any
> error messages in the dmesg log, till I run this command. After I run
> this, I see the following error messages in the dmesg log. I am not
> sure what does that point to...i.e. how it can be fixed.

Probably the kernel sourcs are located on a damaged location on your
hard drive.

> [  629.127668] hdc: dma_intr: status=0x51 { DriveReady SeekComplete Error }
> [  629.127668] hdc: dma_intr: error=0x40 { UncorrectableError },
> LBAsect=1841587, sector=1841583
> [  629.127668] ide: failed opcode was: unknown
> [  629.127668] end_request: I/O error, dev hdc, sector 1841583
> [  629.127668] EXT3-fs error (device hdc1): ext3_get_inode_loc: unable
> to read inode block - inode=58202, block=230190

I am not completely sure, but it looks like your hard drive is dying.
You can try to run a bad blocks test (see man fsck.ext3, I don't have
the syntax at hand).

> OK. I will try doing that as well....since the current file system is
> readonly, I can´t install anything till I reboot :(. BTW is there a
> way to remount the root filesystem as rw after it has encountered this
> error and becomes ro ?

mount -o remount,rw /

But you are risking (further) data loss if you keep writing to the disk.

If I am asked 'How are you' more than a million times in my life I
promise to explode.
[Agree]   [Disagree]

Attachment: signature.asc
Description: Digital signature

Reply to: