[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Partially solved] Re: Locale errors

I ran into this too. Same problem -- extra set of quotes in the environment variables after doing "sudo -i" .

I put

export LANG

at the end of /root/.bashrc and the problem went away. But now that two of us have seen it, I think there's a bug in "sudo -i".


On Apr 12, 2009, at 11:24 PM, Kelly Clowers wrote:

On Sun, Apr 12, 2009 at 20:14, Celejar <celejar@gmail.com> wrote:


So you seem to be correct; for some reason, in the sudo shell, the LC*
variables are getting extra quotes.  Any idea why?  [There's nothing
that looks interesting in root's '.bashrc'; it's basically empty.]

Something to do with the preservation or lack thereof of environmental
variables in sudo? Try putting the env vars in root's .bashrc, maybe?

I don't really know, I use straight "sudo $command" not "sudo -i"

Kelly Clowers

To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: